Cannot change screen resolution

Dear all,
currently I have a screen resolution issue. I have installed the latest version of 15.3 base. I am a linux noob, however, I know to check the forum first before posting a new topic. Unfortunately, former proposals do not work in my case.
The screen resolution is set to 1024768, 4:3. It should be 19201080. As I could not change the resolution to any other resolution, I tried to use the console to add 1920*1080.

Please see here:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*

cvt 1920 1080

1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz

Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync

sudo xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
xrandr: Failed to get size of gamma for output default

--> there is always a "failed to get size of gamme for output default" error message.
Now I can choose between both screen resolutions, although 1920*1080 is still not working as the taskbar isn't showing.

Next, I tried to look for other drivers. But the system does not find any additional proprietary drivers I could use.

Board: Asus Prime A520M-K
CPU: Ryzen 3 4300GE

Any ideas?
Thanks a lot for help!

For detailed instructions on the use of Xrandr in this regard, follow this link. They suggest not using the SUDO command as its not needed for XRANDR commands.

Since you are new to Linux, I am hoping to make this easier on you. CTR ALT F2 to enter terminal.

sudo apt-get install arandr

ARANDR is a GUI front end for XRANDR, making it easier to use. Once installed, click the Zorin logo at the bottom left of the screen, type arandr, launch the app.

Click on 'OUTPUTS'

As you can see, only the connection that you are actually using, is available. Chose which connection that it is, that you are using.

Then go to 'RESOLUTION'

That is where you can set your resolution.

Also, the main issue here might simply be caused by lack of drivers on your system. To get Radeon drivers for an AMD system, please visit this link to AMD's website.

In the list, please choose the one for Ubuntu 18.04

Apparently, they provide installations instructions here.

I have an NVIDIA GPU, which uses NVIDIA drivers, because of this, I have no way of testing, nor confirming anything on your behalf. This is simply, me using some of my time, to help hunt down drivers for you to try.

Hope this helps!

Also, do not use "sudo" to run it. xrandr should be run without using sudo.

You might also try adding it to grub configuration and rebooting:

sudo nano /etc/default/grub

Paste the following line to the end

GRUB_GFXMODE=1920x1080

ctrl+x to exit, hit y to say yes to save and then hit enter to save as current configuration. Terminal will revert to normal. Then:

sudo reboot