Cannot Get Hplip 3-21.2 Installed

I am trying to install HPLIP for my Laserjet Pro MFP M28w printer.
I have tried 3-21.2 3-19.12 and 3-16.7 with no success.

It comes to the part where it requests your password and it does not accept what I type three times and then stops. I have changed my password to a simple character version and it still does not accept what I type in.

Messages Displayed:-


Please enter the root/superuser password:
error: Password incorrect. 2 attempt(s) left.
Please enter the root/superuser password:
error: Password incorrect. 1 attempt(s) left.
Please enter the root/superuser password:
error: Password incorrect.
error: 3 incorrect attempts. (or) Insufficient permissions(i.e. try with sudo user).

I am Zorin 15.3 Ultimate
I am running it as sudo.
Any suggestions would be welcome.

Kind Regards

Your password is the superuser password. That is how sudo (super user do) works. You probably have to install with super user permission, which when it gives you a prompt for password, is whatever you login with.

Are you running it from the terminal or some other means?
Are you running Ultimate core (gnome) or Ultimate lite (XFCE4)?

I am running the Ulimate Core (gnome). I did put my password in correctly and I even ran the original command as sudo.
I am running it in the terminal window.
Is there a way to put some diagnostics into a script that would give me more information about which part of the install process it is asking for my password?

I know I ma putting in the correct password and CAPS is not on and I have made my password very simple.

I really need to have this printer working. I currently have to go to Windows 10 to print.

I ran the installation as non root like the text says and it came up with the below error messages
error: Auto installation is not supported for 'unknown' distro so all dependencies may not be installed.
Please install manually as mentioned in '' web-site

Zorin is not in the script as a supported operating system. I did notice in my web searching that someone said that Zorin was missing and someone helped put Zorin into the script. However I dont know if having Zorin in the script would make any difference.

Can you please open a terminal and enter in

sudo -s

Then run your hplip installer normally and it should not ask you for Root password at all since you will be running from the Root Terminal.

Thread closed. Cross-posting. Missing Module libavahi-dev for HPLIP Install - #7 by carmar