Cannot install anything so far from "software" store and get it to launch

New to Zorin and using core 16.3. Installed fine, I think.

I thought this would be a good alternative to MS, but cannot get multiple apps to install/launch. Latest failure when trying to install the Viking GPS app is "Sorry, something went wrong: Desktop file didn't specify Exec field." All of the apps that came with the distro work just fine...

Lost and frustrated. Searching for this error has returned a whole lotta "try this," but no solution, so far. At this point, and in this instance, I just wanna be able to update my Garmin GPS and create/modify some .gpx files for it without eating up time/space on the wife's business computer, so I'm using an HP machine about 5 years old; don't see any hardware issues there. Hoping for a solution that does not require standing on my head, and squinting through a drinking straw, while typing typing 18 command lines and hoping that works :wink: At this point, if Zorin isn't best for me, please recommend another distro and I'll try. Was hoping for something with windows feel/look without being MS... Thx.

This issue is not due to the OS itself, so it would result in the same behavior in other Linux distributions. The problem lies with a missing line in the package executable. Long story short, it's probably worth submitting a bug report to the developers to address this.

Here's one easy way to fix this problem for this particular software and version... and yes, it involves using the teeeerrrmiiinalll :ghost:

echo "Exec=/snap/bin/" | sudo tee -a /var/lib/snapd/desktop/applications/viking-gps_viking.desktop

You will be prompted for your password, but after that it should launch:

1 Like

Thanks, not near computer now, but will give it a try. Curious that apps appear to install, do not show in the app menu, but I can find then as installed apps in 'software.' Dunno. Lost and will try your suggestion. Thx.

1 Like

So, I typed that script in terminal, was prompted for and entered my password, and got... nothing(?)

Starting to think this is bigger than any program; like I don't have admin rights, maybe??

As a test, thought I would try opening 'Windows Apps' since it is supposed to finish install on the first opening. It did. I then went to PlayOnLinux to install an app It also appeared to install, but is not available/visible to run in PlayOnLinux.

Seems I can't do much of anything since initial install/setup, except use the Firefox to browse the Internet and access this forum. So far no attempted installs have resulted in the app showing up in the 'Z' menu. Rebooting did not help. Thx again.

Are you looking for your Wine apps?

Check your /home/user/.wine directory - that will be the "C:/" drive. Then from there, Program files / Program Files (x86).

For your 'start menu' entries - open the Menu Editor, in the left column, you should see 'Wine' in the list - in that list will be your launchers for Wine apps. You may need to logout / login or reboot to see changes, but you can check the ones you want to show in your 'start menu', or uncheck the ones you don't want.

I'm not very familiar with how Wine or other compatibility layers for Windows software works. However, Viking GPS is available on the Software Store and so you shouldn't have to go that route. The fact that you're having issues with other software could point to something else going on.

Anyway, I just took another look at turns out that someone has done a very lousy job at naming their package (another bug report for the developers...)

First, remove the current installation. Make sure you select the first option, named "Viking". Then, on the top-right corner you will see a drop-down where you can choose between Flatpak and ZorinOS; I would suggest using the latter option, as that is the native format used in Debian- and Ubuntu-based distributions, such as ZorinOS.

Install that, and see if it runs normally.


This definitely looks like an app -packaging bug - These usually happen with Electron based applications. Does anyone know if Viking GPS is electron based?

No, it's written in C and C++:

Also worth mentioning that I did have the same error message when I blindly install the first package that I saw, which was a snap. The second method I outlined above using the .deb package runs without any further action.

1 Like

That's odd, that error refers to the desktop-file responsible for storing some info about the app, like it's icon and what it should run
when it says "it didn't specify the exec field" that means it's a desktop-file that for some reason has an empty Exec line, meaning upon the system trying to run it...there is nothing specified to run

In most cases this isn't a bug with the OS but rather the software you're trying to run, so report this to the appropriate places if you can.

For troubleshooting the existing install, refer to what others said above: remove existing installations, and preferably install the versions available from the Software Store. In most cases Flathub is your friend
(as in, the preferred source to use in the Software Center, see the dropdown outlined in screenshots above)

1 Like

What is most interesting to me: This is the first time I have ever seen any software report that bug on this forum. I have heard of it happening with Electron based applications... But this is the first I have seen a report here. And... the one mentioned is not electron based (Thanks @zenzen for checking).

What a very strange thing.

Wine folder is there. Regarding 'menu editor,' I see know such option, but when I searched for the term, software wants to install it?! Still feelin' like something went bad on the install...

That worked, plus I can see and launch it from the main menu. Thx! Now on to learning the app.

1 Like

Couldn't find a .deb package on sourceforge unless it is wrapped in the .tar.gz.

I extracted the tarball and followed the advice on installation to open a terminal and enter:


I then get an out of date pkg notification:

Forgot to say am testing on Zorin 17 Beta and only just realised (see my later post) that OP using Zorin 16! My bad!

I removed the old app, chose the option zenzen suggested, and chose Zorin OS as the source. Looks like that worked.

Installed from the Store on 17 Beta without any issues:

Oops! Sorry, just noticed OP running Zorin 16!

If you could, please mark this thread as solved by clicking on the "solution" button from the replied that helped solving it. It may be helpful for other people in the future running into similar issues. Thanks!

1 Like

In your main apps menu, should be in alphabetical order, or just search 'menu' and it should pop up. I'm in Mint but, is the same utility:

Might be in a different category than where it would be expected - like if my Firefox were under System Tools. It's not - just as an example..

Yep. Finally got Viking to install/work based on recommendations above, and it finally showed up under 'Science.' I'm OK with that, at least I can "see"/find it now where there was nothing before, thx. Consequently, maybe I don;t need wine now that Viking installed/works, but, not afraid of learnin'.


Done and thx!

(on Z17) this is also available when right-clicking the Zorin Menu button and hitting "Edit Menu"

1 Like