Cannot install from software store

Hello,
so I'm dual booting Zorin os lite (up to date) with Win10 and after few days i was unable to install apps from software center/store with the error message:

software-center

Sometimes the app gets actually installed but after some minutes it just disappears with the same error message.
I have tried to reinstall the store and also tried to install the app using the terminal (sudo snap install spotify)
After i tried reinstalling snapd another "error" message was showing everytime i opened store saying:

software-center-file

Please help, thanks

You do not need sudo for SNAP apps.

snap install spotify

2 Likes

I recommend

curl -sS https://download.spotify.com/debian/pubkey_0D811D58.gpg | sudo apt-key add -

echo "deb http://repository.spotify.com stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list

sudo apt update && sudo apt install spotify-client

For Snapd issues:

snap list

Copy the output to a text file. This way, you can reinstall any missing snaps when done.

sudo apt remove --purge snapd

sudo apt install --reinstall ca-certificates

sudo apt install snapd

If the above fails for snapd:

sudo apt install --reinstall zorin-os-desktop

Should get that fixed up.

2 Likes

Thanks for reply but,
I've tried to install spotify the way you said and that worked (hopefully it won't disappear), but i still cannot install anything using snapd.
Listed commands to fix snapd did nothing and sudo apt install --reinstall zorin-os-desktop showed these errors:

dpkg: ubuntu-docs: dependency problems, but removing anyway as you requested:
 gnome-user-docs depends on ubuntu-docs (>= 18.04.1~) | zorin-os-docs (>= 15.0); however:
  Package ubuntu-docs is to be removed.
  Package zorin-os-docs is not installed.

update-alternatives: error: alternative path /usr/share/gnome-shell/theme/zorin.css doesn't exist
dpkg: error processing package zorin-desktop-session (--configure):
 installed zorin-desktop-session package post-installation script subprocess returned error exit status 2
Setting up rhythmbox-plugin-alternative-toolbar (0.18.0-1) ...
Setting up gnome-sushi (3.24.0-3) ...
Setting up zorin-appearance-layouts-shell-core (2.1.2) ...
Setting up totem (3.26.0-0ubuntu6.2) ...
Setting up libevolution (3.28.5-0ubuntu0.18.04.2) ...
Setting up totem-plugins (3.26.0-0ubuntu6.2) ...
Setting up zorin-connect (1.1.1) ...
Setting up brasero-cdrkit:amd64 (3.12.1-4ubuntu2) ...
Setting up brasero (3.12.1-4ubuntu2) ...
Setting up gnome-maps (3.28.1-1) ...
dpkg: dependency problems prevent configuration of zorin-os-desktop:
 zorin-os-desktop depends on zorin-desktop-session; however:
  Package zorin-desktop-session is not configured yet.

dpkg: error processing package zorin-os-desktop (--configure):
 dependency problems - leaving unconfigured
Setting up libfolks-eds25:amd64 (0.11.4-1ubuntu1) ...
Setting up gnome-contacts (3.28.1-0ubuntu1) ...
Setting up evolution (3.28.5-0ubuntu0.18.04.2) ...
Setting up evolution-plugin-pstimport (3.28.5-0ubuntu0.18.04.2) ...
Setting up evolution-plugins (3.28.5-0ubuntu0.18.04.2) ...
Setting up evolution-ews (3.28.5-0ubuntu0.18.04.1) ...
Setting up evolution-plugin-bogofilter (3.28.5-0ubuntu0.18.04.2) ...
Processing triggers for libc-bin (2.28-0ubuntu1+zorin4) ...
Errors were encountered while processing:
 zorin-desktop-session
 zorin-os-desktop
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also out of nowhere sudo apt update is now showing this error:

E: The repository 'http://ppa.launchpad.net/synapse-core/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Zorin OS 15 Lite?

You can remove that repository:

sudo add-apt-repository --remove ppa:synapse-core/ppa

Then try

sudo dpkg --configure -a

sudo apt --fix-broken install

3 Likes

Fast reply nice,

This fixed the problem and snap works, but discord still could not be installed with another error:

error: cannot perform the following tasks:

- Run configure hook of "discord" snap if present (run hook "configure": 
-----
/usr/share/fonts: caching, new cache contents: 0 fonts, 7 dirs
/usr/share/fonts/X11: caching, new cache contents: 0 fonts, 4 dirs
/usr/share/fonts/X11/Type1: caching, new cache contents: 8 fonts, 0 dirs
/usr/share/fonts/X11/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/X11/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/misc: caching, new cache contents: 89 fonts, 0 dirs
/usr/share/fonts/X11/util: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cMap: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/opentype: caching, new cache contents: 0 fonts, 4 dirs
/usr/share/fonts/opentype/malayalam: caching, new cache contents: 3 fonts, 0 dirs
/usr/share/fonts/opentype/noto: 
<exceeded maximum runtime of 5m0s>
-----)

We can probably fix that... But in this, I recommend Discord from the Repository. OR...
Better Discord.
For one, the Snap and the APT packages for discord are exactly the same.
Two, the Apt package works better and meshes better.
If you really just prefer Snap, please see post #8 here:

3 Likes