Cannot install qt4 libraries to Zorin 16 for Epson L3110 printer

I need to use an Epson utility to troubleshoot my Epson All-in-one L3110 printer. It will not run without qt4 libraries. I have found articles that say qt4 was removed from ubuntu 20.04. I found instructions on installing qt4, but they do not work (anymore). Here is my terminal session trying to install the libraries:

jim@Jims-Ryzen-Desktop:~$ sudo add-apt-repository ppa:rock-core/qt4
Cannot add PPA: 'ppa:~rock-core/ubuntu/qt4'.
The team named '~rock-core' has no PPA named 'ubuntu/qt4'
Please choose from the following available PPAs:

  • 'qt4': Qt4 for Ubuntu 20.04

I am confused by the suggested remedy. All help welcome.

Jim, I just tested this and the PPA added fine. So, I suspect it is due to a branch you are on.
Can you please try:
Open Software & Updates from the app menu
Look at "Download From" on the window that opens - click the drop down menu - set that to Main server

Once done, try adding the PPA again.

Thank-you, Aravisian. I did as you said and the install worked. Download from was set to United States. I'm in Costa Rica. However, I still get the same error when I try to start the printer utility. Here is the session:

jim@Jims-Ryzen-Desktop:~$ epson-printer-utility
epson-printer-utility: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: No such file or directory

Ok. The library issue was resolved with:
sudo apt install qt4-default

However, now the error is:
jim@Jims-Ryzen-Desktop:~$ epson-printer-utility
Communication daemon down, Error code = -1

I'm concerned about pursuing this here because you resolved the error mentioned in the Subject of this post. This is really a new topic.

I do not know why the communication daemon was down, but restarting the machine eliminated the error. The printer utility is now running. I will, however, mark your fix for the library install as Solved, because that was the original topic.

1 Like

Jim, I logged in as you were getting it all sorted out. All you needed was to believe in yourself. :wink:

1 Like