Cannot install Zorin 16 Pro

I've read.
Sounds like there is no solution....

Long story short I would not recommend using a 10th gen comet lake on ANY of their boards . Not only because of the SGX issue but their bios is geared toward rocket lake .

@Heyrer2 Here a possible solution

If you can not enable SGX in firmware you can add the boot option nosgx so the kernel will not try and use SGX when it detects the CPU supports it.

1 Like

It sounds good.
Guide for your bios.

@Heyrer2, if you read this please try this. nosgx command will fix this.

To temporarily add a boot parameter to a kernel

  1. Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left esc key or shift right after starting the system).
  2. Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.
  3. Go down to the line starting with linux and add your parameter nosgx to its end.
  4. Now press Ctrl + x to boot.

To make this change permanent

  1. From a terminal (or after pressing Alt + F2) run:
 sudo gedit /etc/default/grub

(or use sudo nano if gksudo or gedit are not available) and enter your password.
2. Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append nosgx to its end. For example:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nosgx "

Save the file and close the editor.
3. Finally, start a terminal and run:

 sudo update-grub

to update GRUB's configuration file (you probably need to enter your password).

On the next reboot, the kernel should be started with the boot parameter. To permanently remove it, simply remove the parameter from GRUB_CMDLINE_LINUX_DEFAULT and run sudo update-grub again.


Did you trying this? @Heyrer2

Hey @Heyrer2 can you please navigate to the "advanced" section of your BIOS and check the status of "Software Guard Extensions" (if available...but i think it is).

I am talking about the "advanced" menu in the top.
If it is disabled, then enable it.

1 Like

Ok let me try guys

Oh but guys , right now I m using win11 , I installed it again ,like I cannot really use the commands you sended me above

I cannot install ubuntu too , I get the same sgx error

Did you try enabling "Software Guard Extensions" from the 'advanced' menu in BIOS? SGX stands for Software Guard Extensions.
I don't whether you need to enable or disable it...Just try the opposite of whatever is set by default.

1 Like

Did you try this at all ?

Hey I searched now in it and again I DON'T FINE THE SETTING

1 Like

So I should write in the grub boot "quiet splash nosgx" ?

The only reason I said that is because I found this image in google...which looks exactly like your bios.


After the SMX part , I cannot find the SGX one sadly...:disappointed_relieved:

You know, maybe the processor supports sgx but the manufacturer did not expose it in bios.


I m going to go back to windows 10 , look what I found : Intel Core i710700KF Processor 16M Cache up to 5.10 GHz Product Specifications

Intel® Software Guard Extensions (Intel® SGX) : Yes with Intel® ME ( this is only avalable on windows 10 )

I am sorry, I don't understand. Are you saying you are ditching linux?