Cannot install Zorin 16 Pro

Hello everyone ,
I bought two days ago Zorin Os Pro and it just doesn't work at all to install .
I'm having a PC with these specifications :
Motherboard : TUF GAMING B-560 PLUS
Processor : Intel i7-10700KF CPU ( 3.80 ghz )
Card : rx 5700 xt
System : Windows 11 Pro
Mode : UEFI
So I followed the installation tutorial , and I did everything right . I cannot use balenaEtcher to make my usb bootable , I destroyed an usb with it :unamused:
So that's why I bought another usb and I formated it to ntfs and just drag and dropped the files from the iso file to my usb . Now I went into my bios and I disabled secure boot , tpm ( everything that was needed for accessing the boot menu ) . After this I restarted my pc and I pressed F8 so I got into the boot menu where I selected the first option * TRY INSTALL ZORIN OS .... * , then after few seconds I got this message : [ 0.4553435 ] x86/cpu : SGX disabled by BIOS ( after it other text if its needed I can send the full image )
I was thinking that this error is coming from the bios settings and I tried to change a lot of things , but AGAIN I got the same error .
After all this I selected to try install in SAFE MODE and there everything worked fine . But I don't know if it ok to install this in SAFE MODE and I really want to install everything normal.
I searched on web for SGX error , and I found some drivers that should be installed ( sadly all the drivers are for windows 10 I installed this one on my pc too but it didn't help : to make it work ( because on MY BIOS I didn't find the option to enable or disable SGX )

I don't know what to do , I'm trying to fix this by myself for already 2 days and I cannot do anything . Please help me

Hi and welcome to the forum :slight_smile:

There are a few preparatory steps required before you install any and all Linux distros.

Please have a look at this tutorial first:

If you find yourself unable to understand it, you could also contact Zorin developers since you have a Pro licence which comes with a installation assistance. The best way to contact them is to reply the confirmation email you have received when you made a payment. (Be patient to get their reply. There are only 2 people in the Zorin group.)

Hi again , thanks for your reply .
The problem is not on partitioning part , the problem is that I cannot even access the installation page. But if you cannot help me with that I will contact the pro support ...

That page I made a link above talks about more than partitioning.

But if you need a quick fix, I can tell you that secure boot must be disabled at minimum.

I did this and it still doesn't work ...

Welcome to the club - you are not alone:

If you are dual booting with Windows, there are other steps to make. Please let me know.

I want to install Zorin as main system not dual boot

Is your internal disk eMMC or SATA?

SATA ( I got my main system (win11) on ssd and an external hdd )

You set your disk as AHCI, not RAID in your BIOS I suppose.

But is it a problem is I install zorin os with the safe mod installer ? Will be something different out there ?

Is there a option in the bios to enable sgx ?

No sadly it isn't , I wrote this in my thread

Safe mode just means not using any proprietary GPU drivers. It only affects people who uses separate Nvidia graphics card like myself.

The only other solution I can think of it to reset BIOS to a default settings.

If you can wait for another few hours, there will be more volunteers form US who are much more experienced than myself. Due to the time difference, there is not much of people at the moment.

Sure no problem , but anyways thanks so much for your help, I will wait

1 Like

Oh and I wanted to ask again , should I reply to the message where I received a key?

You could do that.

But sometimes people find it faster to ask volunteers here.

1 Like

I would suggest to use a usb flashtool to use to copy the content of the .iso to usb disk.

You have a few nice options.

  1. Rufus
  2. Unetbootin
1 Like

I tried rufus but there is only the ntfs option not the fat32 one

I think the problem is because of that.

Did you try to recover the older stick ?

1 Like