Cannot Install Zorin iso 16.3 pro 64-bit

Greetings All,
i have installed Zorin on my pc many many many times..
this round.. not sure what the hek is going on.
was hoping someone can assist with this madness !

created 4 bootable usb sticks with zorin iso
using rufus , etcher etc -
NOTHING is working -
First errors were the following after selecting which ZORIN i want to install

error: invalid magic number
error: you need to load kernel first

after many formats erased usb stick etc etc i am now stuck on this
either one screen or the next, i cannot for the life of me figure this out!!!!!

What's the device being used?..

Tried to install Linux on an older Asus tablet but, didn't get far. Has a 64bit CPU, 32bit UEFI :person_shrugging: didn't think about using a 32bit distro at the time but, may work..

Have you ran a disk check on your USB used for install; or were more than one tried?

1 Like

Thank you for the response,
this is a pc , that has had zorin installed for 3 years, with no issues,
i have installed zorin on this machine multiple times in the past 3 years, more than 9 times using the same iso - for some reason it just wont go through now.
yes i have tried 4 usb sticks

1 Like

To test further , i tried downloading version 17 core .iso and it worked , I am able to install with no issues.
i tried using different copies of my .iso
is there anywhere i can download zorin 16 pro 64bit iso again ?

UPDATE - i just ended up purchasing 17.1, i hope this works once i make the usb again ! lol - if not i just wasted 67 bucks...

In your confirmation email for this purchase you should have a download link for it.

1 Like

Were Secure Boot and TPM disabled? Were the USB Sticks formatted in FAT32?

1 Like

Did you check the SHA256 checksum of the 16.3 .iso before burning it?
(assuming you have kept a record of the correct SHA256 text from Zorin for that version)


couldnt get to my email as my pc was down - :frowning:

yeah didnt have that info, that is why i was interested in grabbing another copy of the iso for 16.3
i grabbed the 17.1 all is well, just trying to remember how i configured the dual boot that does not seem to be working at the moment

BIOS is older so i dont even have those options.
yes sticks were formatted as FAT 32 even tried other flavours,
at this point i think the ISO was bad.

1 Like

Give this a try: format the USB in NTFS, then extract the .ISO file to the blank USB - then boot from the USB; you don't need to set any flags or partition options. Just a blank NTFS partitioned USB..

If that doesn't work:

If that's the case - try using Unetbootin; lots of my older BIOS setups prefer that method.

And if it is a bad download - neither of those will be doing any good :joy:

I'm not entirely certain if FAT32 would partly be causing something or not though .. :thinking: ..

Definitely give your BIOS a good poking around; see what all options you have with security / boot / USB..

1 Like

Do you want to Dual-Boot with Windows? In this Case You don't have to configure something. Choose in the Installation-Process the Option to install Zorin alongside Windows. Then all will be done automatically.

And when You now have Zorin 17.1: Do You have checked the Checksum of that?

Because of the USB Stick: When your BIOS is older ... On Rufus You have the Option to choose between GPT and MBR for the Boot-Stick. You could try both if You still have Problems.

1 Like

I can't really contribute much to the main topic, I'm new to Zorin.
But in case you're using two different drives for each OS:
I had a running windows system and installed Zorin on a new drive (I initially removed all other drives because I didn't want grub, ended up installing it with them plugged in though) and now I get a dual boot menu by Zorin on startup itself without installing both OS on the same drive. That's pretty cool, dunno if it's common knowledge though. :smiley:


ha-ha, good call , but tried Unetbootin as well.
as mentioned, at this point i believe the culprit was indeed a bad .iso,
it may have become corrupt somewhere along the way

1 Like

thx for the response,
Zorin is my MAIN os, and windows is on the side

I downloaded 17.1 pro slapped it on a stick with rufus and the rest is history !

yes ! the first few times i installed windows after zorin i had the same experience,
this time though it didnt quite work so well for me,
i may redo to see if it helps - no big deal, but in the meantime i just hit F9 and select where i wanna go .... meh..

1 Like

Usually the opposite when dual-booting - just saying :smirk: Nothing wrong with it but usually entails some issues when booting and all. The most preferred way is to install Zorin / Linux after Windows. But, it can be done the other way around! :+1:

Now, if you have both installs there and don't want to do anymore reinstalling - just run the Boot Repair tool in the live bootable and rewrite the Grub; which will find both OS's and add them to the list when booting. Trying to save you some time, really - reinstalling Windows is a long task itself, for me anyway.


Yep! That's what Grub does :grin:

Even if you don't dual-boot, you'll have Grub. Some distros hide the select-able options by default so you have a faster booting device; and if issues happen, you can use keyboard interruptions to get to the options and repair from there in the rescue shell.

Basically, Grub finds your OS's - via partition or separate disk - places them in boot options in Grub, then when you select the OS you want to use - Grub 'points' to that loader and starts the boot process, and into the kernel from there :+1:


Good to know, where is Grub installed though? Is it on the Linux drive in my case?
If I boot from windows boot manager, it won't show up?
I'm kind of scared by Grub crashing at some point and not being able to boot anything anymore. :smiley: That's why I didn't want to install both on the same drive.


Turning into a discussion at this point - I'll PM you some stuff about grub :+1:

1 Like