Cannot install Zorin on Desktop because of intel RST, RST unable to be disabled

Hi guys,

I've been doing a big switchover today from windows to Zorin and unfortunately I am running into more trouble. I followed the instructions at Intel RST which the Zorin install suggested, unfortunately they have not helped.

When I use regedit to change the values to 0 they are reset once I reboot the system. My bios seems to want to re-enable RST every time even when I go in and switch it to AHCI.

At first I believe it was because of the optane drive in my system. So I uninstalled it and tried again. Didn't work. So then I removed the optane drive entirely. Same issues.

The drive that I am wanting to install to is an NVME SSD (WD black 1tb) and it is completely fresh with nothing on it.

The installer keeps on flagging RST as the problem, but I'm out of my depth troubleshooting this. (I am headed to work so may not be able to reply to any help until tomorrow)

For NVme, the correct setting is RAID, not AHCI, I think.

I managed to get AHCI to stick, and the installation process seemed to be working. I'll update when I get a chance to check on it


I will double check with other volunteers regarding the settings for NVme:
@Aravisian @337harvey @Michel

1 Like

Hello again,
I managed to get everything installed but sound is not working. I tried disabling the internal audio chipset so I could use my sound card but that didn't work.
I also used this Zorin forum post but it didn't solve the issue:

I am now trying installing Jack through ubuntustudio as I have heard that has helped some people.

Or one of those.
Priced between 6 - 20 Euro.

Could you please tell us make and model of soundcard? As for chipset did you disable it in the BIOS? I had similar issues with my Sound blaster card, 5 Rx, and blacklisting helped initially but what really helped was installing ALSA and then create a folder in /etc and name it 'pulse off' without the quotes and cut and paste 'pulseaudio' folder in /etc into 'pulse off', this way you don't damage the system. You will need root privileges to alter things in /etc so in a terminal cd.. to / takes 2 x cd.. in the terminal to get there then;

sudo chown [your user name] etc

Then follow the guidance above. Also install ALSA tools. This should include QAS Mixer which when opened you should see your card beneath the sliders unchecked. Check it and you should get sound.


it is the soundblaster audigy rx. I both blacklisted in Zorin and disabled in the BIOS

I might buy one of those to see if I can get input working again. With Ubuntu Studio I got output working and it is nice and high quality, but I can't sort out the mic. Since I spent some money on the sound card a while back I am wanting to use it until I could invest in a nice DAC


See my answer above your last post. :wink:

1 Like

Did this get both your output and input working?
I managed to get my output working using Jack and QASmixer, but no input. Because of the way Ubuntu Studio is I'd have to do a fresh install to try your solution :frowning:

The input is via webcam which shows up if I switch to record sliders and I use the webcam for Jitsi meetings, as I don't have a mic to play with. Having said that not tried broken headphones that does have a mic.

I think that tomorrow I will go through and try to do your solution on a fresh install. Could you tell me the command you used to install alsa?

Unfortunately I am not sure what you mean here

1 Like

I'll go on my PC and boot Zorin to post pictures of Synaptic Package Manager of all things ALSA installed.

cd.. in a terminal as in Windows CMD = change directory. When you open a terminal you are at /home /your username home folder. So cd .. first takes you up to /home, second takes you to root directory where etc (and /home) reside. :wink:


To put this another way, entering cd .. just as you see it there, in terminal, moves the directory up by One Directory up.
It is the same thing as hitting the Up Arrow on the toolbar of most File Managers (But not Nautilus File manager, the default Gnome File manager.)


Thank you! Hopefully that will help solve my issues. If you just have what package you installed so I can grab it that'd be great too.

Image 1:

Image 2:

Image 3:

All the packages with the green squares.

When you start Qasmixer you will see your sound card at bottom of sliders as in screenshot, unchecked - check mark it and you should hear a slight pop!

As for Synaptic you may not see them in full order as when you press 'S' at the top of the bar where the squares are this brings up all your installed packages after I did a search for 'alsa'. :wink:

Now for applications that work with ALSA - Audacious and Kaffeine and Rhythmbox. Videos (the application) will play sound but not video, but Kaffeine plays both audio and video (Kaffeine is if you had not already guessed a KDE application, not a Gnome one and was built around the superior ALSA, that is superior to Pulse Audio in every sense, and here's why from the ALSA project web page:

You will also need to ditch Firefox as it no longer supports ALSA, that is why I have installed this brilliant browser:

Hope you get your sound friend!

Just launched Ardour which is recording application:

You can see it is using ALSA and picked up the SoundBlaster Card in Midi Setup.

Computer folders:

etc folders (pulseoff - which you need to create after taking ownership of etc):


pulse - not pulseaudio - my bad - pulse audio looks for this to start - if it is not where it is supposed to be it will never start!


This is what I mean fellow Zorin users, Where are you going to find people that take the time @swarfendor437 took to upload and direct solid information of this level (and this isn't even his goto distro) for free. No where other than RIGHT HERE! I am always in the background gaining knowledge and Once Again Amazed!! TYSM for info put in my toolbox (even if I don't need it now)


Thanks for the compliment friend. To be fair I gleaned knowledge about moving pulse from someone who contributed on Ask Ubuntu and it got a minus vote which appalled me. What I share is what I have gleaned elsewhere or tinkered with myself, mainly in respect of throwing all ALSA packages into the kitchen sink which may not always be necessary. :wink:

1 Like

Thank you so much! I tried it and it got my sound working!

Still gotta go through and try with the microphone but worst case I just get one of those small adapters @FrenchPress suggested for just the mic.