Cannot open links when chose brave browser as default

Hello everyone hope you are doing good!
I have a small issue I request you to look upon. I just downloaded brave browser and set it as default. But then whenever I click on any link, it shows the error as seen in the screenshot. I reinstalled brave twice, still the issue persists.
Kindly suggest any solution.

Are you using Flatpak, Snap or APT installation for Brave Browser?

1 Like

Thank you for the reply.
I am using it through APT install.

UPDATE: I went to default applications -> others and went to each entry to make it open with brave browser. As a result, some of the things are working and opening in brave, for example live server extension in vs code. But in the those entries, even though some of them contained 'web-browser' initially would not allow me to change it to brave entry. I think as a result, opening simple links is still not working and displaying the same error.

Also same is the case with clicking emails. Even if i have not changed default application from mozilla thunderbird, it still displays the error.

Any solution to this?


1 Like

Thank you for the reply. In the link you provided, I executed the commands given, namely;

sudo update-alternatives --config x-www-browser
sudo update-alternatives --config gnome-www-browser
xdg-settings set default-web-browser brave-browser.desktop

Even then the results are not as needed. Any links, for example in a pdf document(as in the screenshot) are not opening resulting in the same error as before.
Kindly provide any other solution if possible, thanks in advance.

You can check with

flatpak list


snap list

To see if Brave is a Flatpak or Snap.
These are the recommended methods for installing Brave Browser:

1 Like

I've always had problems with pdf's opening in Brave when I don't want them too. I always right click a pdf in nautilus and go properties>Open With>Master PDF Editor>Set as default. Perhaps the reverse will work?

With regards to all of this. I find it best to remove Firefox as soon as I install any distro. I don't even open it. If I do that everything in Brave seems to work automatically and I can still add a Firefox type browser later.

1 Like

Hello brother, based on the link you provided, I executed the commands, and it gave me errors in every step, and as a result not only the problem was not solved, but it gave me another problem.

E: Type 'β€œdeb' is not known on line 1 in source list /etc/apt/sources.list.d/brave-browser-release.list
E: The list of sources could not be read.
This usually means your installed packages have unmet dependencies

This error is constantly displaying in panel in software updater item and same for sudo apt-get update && upgrade. The software updater is not opening and I am now getting the same error when executing the commands from the link you provided too.

Kindly look into the issue and help.

First, we need to fix your sources.list
In terminal, elevate to Root:

sudo -i

Open the file manager


Core (Gnome users will enter in nautilus instead)
In thunar, click the Up Arrow on the toolbar a couple times, then double click on etc, then apt then souces.list.d
Once in that folder, locate the Brave-Browser repository file and Right Click on and delete it.
Once done, close all that out.
Open terminal and run

sudo apt update

and ensure your sources list is running properly.

I have tested and checked the commands supplied in the Article and they work. I can only hazard a guess that a quotation mark (") was misplaced when you ran that command in terminal. Did you Copy and Paste that command into your terminal when you followed the article?

1 Like

Thank you for the quick reply and detailed guide. It fixed the issue.
Coming to your question, yes sir i have copy pasted the commands carefully. And as a matter of fact and as an extra step of caution, i installed brave browser from the software center as snap install (it has this only option). But still the same issue persists from the beginning. And as i also told previously, the mime helper error also displays for Mozilla Thunderbird when clicking any email address link. I have not tested for other applications hence cannot say.

I believe that the Snap Version of Brave Browser may be the cause, since Snap is a Double Sandbox; isolating the Browser away from the rest of the system.

This is why I was hoping to test using Brave as a proper .deb package.

1 Like

Yes it can be the case. But no major issues sir, as i have changed every entry in default applications -> others - 'web browser' to brave browser (it does not let me change some of the entries though). So i will make a habit of copy pasting the links whenever i have to open them from a pdf doc or similar.
I appreciate your quick replies and whosoever you are, a volunteer or a paid Zorin team member, I would have donated if i was not a student. I will mark this as solved with thanks.

None exist, actually...
We are all volunteers, here.

You may try the following:

sudo apt install --reinstall xfce4-settings zorin-os-lite-desktop

Then test.

I executed it but then now a new situation arises. Now in default applications i have two options to choose brave and brave web browser. I reinstalled brave from software store and re executed the command and reboot, but no change. And also in brave settings, after clicking the make default option in startup for brave, it still displays to make the web browser as default. On the top of it, when i click on it, nothing happens. This all is so bewildering for a noob-beginner like me.
And now i know that you are a volunteer, I have more respect for you for taking time out and solving user issues. People like you and the open source concept are the reason i love Linux so much.


sudo apt remove brave-browser

Then check if you have only One Option for Brave-browser in the app menu.

I am a bit bewildered, too, actually. I used to use Brave Browser and installed it in much the same way as the guide I linked you to above. I never installed Brave from the Software Store.
And it set as default just fine.

1 Like

I executed sudo snap remove brave cause the first one being obviously that it was a snap install and second one being that it displayed that snap "brave-browser" is not installed.
It uninstalled brave successfully.
And i am still getting an option for brave web browser in default applications don't know why.

Can you run

flatpak list

And look for Brave-browser

apt list --installed

Look for brave-browser...

1 Like

I checked sir brave nor brave-browser is listed in any of the two cases..

You may just have a left over .desktop file, then.

sudo -i


navigate to /usr/share/applications and search for a Brave-Browser Desktop file and remove it.

Once done...
Close that all out and open a terminal and run

echo "deb [arch=amd64] stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list


sudo apt update && sudo apt install brave-browser

Then test if your Defaults will accept.

1 Like

Sir in this case, brave-browser desktop file was not listed in the folder despite me checking twice..
And then i ran the command given. Its output:

deb [arch=amd64] stable main

After than sudo apt update went well but for second condition it displayed error as below:

W: GPG error: stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8580BDC82D3DC6C
E: The repository ' stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.