Cannot upload PDF - not a supported format

I printed an email chain to pdf from however when I tried to upload it to a site (a pretty standard site with an upload document feature) the site rejected it. I tried on a few other sites and received error messages like the

"This file type is not supported. Please check our upload formats and requirements and try again."


""the pdf in question" is in a format not supported for editing with comments."

But its just a pdf. I then copy pasted the email text into libre writer, exported to pdf from in there and was able to upload that pdf.

One thing that is interesting is the pdf that I printed to pdf from my email in my web browser does not have a thumbnail whereas the pdf that I exported from libre writer does. And that was the one that worked.

This sounds like Outlook did something to the PDF that you downloaded that made it unrecognizable by those other websites.

possibly. but i never had that issue on windows before and would use this feature frequently. The pdf opens fine but just could not be recognised when uploaded.

Was that pdf created from web browser viewing or from an email client e.g. Thunderbird?
I have in the past found pdf unable to be recognised (even on Windows) depending on how it was "printed" and from where it was printed.

it was printed to pdf from the web browser. I have been doing this for years in windows. I am using Ghostery as the browser which Im curious if that may have anything to do with it...but I would doubt it.

How was that installed e.g. apt, Snap, Flatpak?

good question. I can't remember. is there anyway to see that?

looks like I got it as a flathub from the software store. That said, it took an age for the result to load in store has been really slow lately.

Well, this is intriguing. PDF is an open standard document format, so there's no reason why it should behave differently unless something has changed during the download. Then we have Ghostery, which is developed by an advertising company, and has been caught red-handed in the past doing things like injecting ads without user knowledge nor consent...

A quick test, try using another browser and see if that makes any difference?

And just to throw in some ideas, is there any chance that this could be an issue due to file size, rather than the format? It may be worth reaching out to the support teams from those websites to get some input from them.

As for the package format installed, in a terminal you can run flatpak list or snap listand that will print out all your packages installed in the respective format. If it's not in either of these formats, then it's installed in the native .deb one.

wow, I didn't know that about ghostery? I really liked using this browser as it was pretty fast and did a lot of blocking it seems!

Very very interesting. I just accessed my webmail for via Brave browser and everything worked just fine. Sorry I really should have checked that before, but I was having a few issues with Zorin I assumed this was another.

So what does that mean...Obviously Ghostery has to go now. Shame. I liked it.

1 Like

To be fair, I cannot claim that this is what's happening here nor that they are still involved in any business of the sort. But something to be aware nonetheless.

Any chance you could try Firefox as well? Ghostery Browser is really just Firefox with their extension installed and a few extra tweaks, so it's possible that the issue is with Firefox itself.
It would be interesting to try to reproduce this issue with other PDF files, for good measure.

Either way I think you should check the PDF files downloaded from each browser. You can run these two commands in a terminal, one at the time (I'm assuming the files are located in the downloads folder, adjust the location and name of the files as needed):

sha526sum $HOME/Downloads/ghostery.pdf $HOME/Downloads/brave.pdf
file $HOME/Downloads/ghostery.pdf $HOME/Downloads/brave.pdf

The signatures produced from the sha256sum command look like a long string of alphanumeric characters, and should be the same for all files. If the signatures are off even by one character, something is wrong.

The file command detects the file type and should look something like "PDF document, version 1.5 (zip deflate encoded)". I wouldn't expect this to reveal anything significant, but I suppose the version number could be a reason why the PDF files are not being properly detected by those websites, even if they are legitimate, so it's worth checking just in case.