[Canon Printer-MX410] Settings / Add printer not working

Dear Support,

I'm trying to install my printer Canon MX410 but when i try to add it via the settings i get this error message (see screenshots below):



Could you please advise/support?

Zorin does seem to recognize it when plugged in to a usb port. The printer also has a scanner.

Thnx in adv!

Best regards,
GaiusMarius

I see two MX410's in your list, did you try to add the other one? Normally if your system is lacking the driver for a printer, you will only see cups.

For example, I have an HP LaserJet 2100TN printer, and even though there are HP printer drivers already installed, the driver for laser printers was not. So all I saw was CUPS. So, I went into my Synaptic Package Manager, and I installed the HP printer driver for laser printers, that allowed the system to find my printer.

Since Zorin OS appears to be already finding it, it appears you already have your driver installed. Please make sure that the printer is ON and in a READY standbye state. If the printer is OFF, or in error state, it will not connect to your system.


Hi StarTreker,

I've tried both and they both return the error.

I'm able to scan documents via VueScan but printing is problematic since the openOffice for example doesn't see the printer.. Following the install of synaptic and installing the mx410 driver its still not appearing..

Would you have any other suggestions?

Best,

Just in case you did not know, we are all volunteer here and have no connection to Zorin Group.

As @StarTreker is taking a leave of absence at the moment, I will try to answer your question.
Make sure you install apps from .deb installer.
I once installed OnlyOffice in FlatPak and it could not see the external drives nor printers.

I am afraid using Synaptic is not a correct way to install propitiatory printer drivers. This method only works for HP printers which have a full Linux support.

You can download its driver here:

2 Likes

Hi FrenchPress,

thank you it worked! Was able to install and set as default. Now its recognized! :slight_smile:

Screenshot from 2021-11-27 16-18-03

2 Likes

Glad to hear that now the printer is working :slight_smile:

I just tell you something to remember for the future reference.

Most printers are NOT natively supported in Linux except for HP.
HP provides the famed HPLIP (HP Linux Imaging and Printing).

If anyone advise you to install a driver in Synaptic, do double check.
You are lucky not to damage your system but I saw one case where the person had to reinstall Zorin OS after a wrong operation in Synaptic :scream_cat: