Can't boot and Boot Repair isn't working

Hello, I am having some trouble with Zorin on an Asus laptop.

Installed a couple days ago, and it has been more or less working fine, but today it stopped being able to boot.

Have gone through a couple of cycles with Boot Repair. I got "NVRAM locked" errors, which I hoped to fix by resetting the CMOS. Took the laptop apart as much as I could, but couldn't locate that type of battery, and am not even sure if that's the right thing to do. I ended up downloading the BIOS flash tool from Asus and flashing it.

This time Boot Repair told me I needed to disable Secure Boot. It was off before, but apparently flashing the BIOS re-enabled it. So I disabled it again. Now Boot Repair runs for a minute, then stops with the message: "grub-efi purge cancelled".

Here is the Bootinfo summary:

Perhaps I need to re-install from scratch again, perhaps I just need to trash this laptop and buy a newer one.

Thanks in advance if you can help!

Did you run Boot Repair from LiveUSB?

Yes I did

Maybe I am missing something, but I do not see anything out of place on your boot repair report.
This part:

sda:1000GB:scsi:512:512:gpt:ATA Samsung SSD 870:;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
sdb:7756MB:scsi:512:512:msdos:Kingston DataTraveler 2.0:;
Free space >10MiB: ______________________________________________________________
sdb: 4.39MiB:2472MiB:2468MiB

raised an eyebrow - I would try using a different USB stick if possible.

As the installation is only a couple days old, I would go ahead and just wipe and reinstall if this was me.

Hmm, I can give another USB stick a shot. What looks wrong to you about it in the report?

Hoping not to reinstall if at all possible!

It looks Very Filled...
It is best to have at least double the space you need in case there are bad sections on the drive.
If you fill the drive with data and there is a corrupted sector, it can and likely will fill that sector if it is running out of room.

The sdb is full, which is his USB thumbdrive.
SDA is the NVMe drive with a TB available for use. It is curious that only 540MB is in use though. @snailwhiskers Is this Lite or core?

The grub repair seen the EFI partition, FSTAB on the system partition and even read the grub file. You can scan the drive (using the live image) for issues and have the sectors marked at least. It is possible the drive has issues or is failing (even brand new drives are still susceptible to failures).

You can rerun the installer, choose not to format system (something else method). This will require you to reinstall applications, but your customizations and personal files, if any, should continue to exist. Be sure to define the partition to install grub to, not the disk but the partition and format it.

The first USB thumb drive is a 5GB drive, I flashed the Zorin ISO to it using Balena Etcher, so I'm guessing it partitioned it so that there wasn't much free space. I tried again with a newer 8GB flash drive and am seeing the same result ("grub-efi purge cancelled").

540MB in use does seem odd. I am using Lite, but I set it up and copied a bunch of files on - I think it should be roughly 200-300GB used. It is indeed a brand new SSD; it hadn't even occurred to me that that could be the problem, but of course it could!

I will give those suggestions a try, thanks!

OK, I ran an extended SMART self check from SMART Data & Self-Tests, no problems found.

Can't figure out how to do the partial reinstall, the partitions don't seem to be right, so I'm going ahead and reinstalling from scratch ("Erase disk and install Zorin OS" option).

However, it seems to be stuck about 1/3 of the way through "Creating ext4 file system for / in partition #2 of SCSI1 (0,0,0) (sda)...". I'm suspecting some kind of hardware issue, but not sure how to narrow it down.

I'll let it sit for a while and see what happens, but if it won't install then maybe later tonight I'll open the laptop back up and put a different drive in.

Are you set to RAID or AHCI in your BIOS settings?

AHCI (only options are "IDE Mode" and "AHCI")

Also "CSM Support" is Enabled, not sure if that matters or not.

Update: I ended up deleting all the partitions manually with GParted, and then I was able to install Zorin Lite OK. I'm now having some issues with moving files onto the SSD, but perhaps that should be a separate topic.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.