Can't boot into computer after installing Zorin OS 16

I'm new to Linux and have slightly used Linux Mint in the past.
I wanted to completely shift over to Linux and saw Zorin and decided to make it my go to.
I installed Zorin through a USB drive on my laptop.
I installed Zorin to be my sole OS going forward.
After I followed the step and installed it, it prompted me to restart my Computer to use the OS.
I did so, but now I'm not able to enter my computer.
I'm using an HP ProBook 450 g2 and it just keeps looping on the HP logo and keeps restarting in UEFI mode.
In the Legacy Mode, it goes a bit forward and gives the error of can't find Boot device.
I need help as even the USB is not working as a bootable drive. Even after re ordering the Boot order.
So I'm kinda stuck.

Do you have Nvidia Graphics?

Are you dual booting with Windows?

1 Like

Switching to legacy after installing zorin by efi will not help you. Legacy won't recognize gpt. If you wouldn't mind sharing a little more info, which version of Zorin did you install (16 core, pro, 15.3 core, lite), what is your graphics card (nvidia, amd, Intel) and which method did you use to install Zorin? Did you format and repartition the drive prior to installing?

I installed the Zorin 16 Core.
I have an Intel microprocessor with no other graphics card.
I installed using the first option that comes when installing Zorin OS.

I don't have a graphics card and I'm not dual booting.

Ok, integrated Intel graphics, full drive wipe and install... I'm wondering if the efi wasn't created properly.

Try booting back into your usb thumbdrive... start the installation again, this time choose something else. You will get to a screen with your partitions listed at the top and a dropdown at the bottom asking for the bootloader placement. In the top take note of the efi partition (500mb) and what it is called, on the left side (sda1, nvme0p1, etc). In the drop down at the bottom left choose that partition.

In the top window again you'll see two ext4 partitions. One the size of your ram (4, 8, 16, 32gb...), select it by left clicking, then hit the gear immediately under the window on the left side next to the plus and minus. Left click the "Do not use this partition" and change it to ext4. Set the mount point to /swap. Click ok. Select the other ext4 partition and hit the gear. Choose ext4 again. Mount point /. Hit ok.

Neither should be formatted. These will be mounted but basically ignored by the installation. This will reinstall grub. Finish the install.

If this allows you to boot, go through every part of the os you would normally access. You're looking for oddities, things out of place, missing out other issues. The bootloader may have been the only issue, but if not one more try of fresh install with formatting (same way as described above) should fix it. If still an issue I'm wondering if your drive is faulty, needing replacing. That may be covered by warranty though. I'm getting ahead of myself.

That is the issue though, my laptop is not letting me boot from USB for some reason. Even though I've set the Boot order and everything.

What is your usb formatted as?

I think exFat.
I installed using the USB so this doesn't make sense for it to happen

Which program did you use to create the bootable usb?

Exfat supports larger file sizes, but not all bios's recognize it because it hasn't become a regular standard. Manufacturers want to get their systems out with the smallest bios (less coding) even if it doesn't support all the fs's available.

Your usb could also seen its end. Depending on how much you have used it. Try rewriting the iso to your usb from another writing software. Rufus, unetbootin are both commonly used and recommended here.

I'll try

Should I format the usb and set a different type?

I'm trying this method but I can't find the second ext4 that you are talking about, there is only one in my case.

Ok I found success.
But first, what I tried.
I tried reinstalling the OS but that did not change anything.
Then I plugged my USB back in, this time I went into the UEFI firmware settings.
After doing so I chose the Boot device option. In it there were multiple options.
First of all I chose the EFI option and gave it a path to the Bootx64.efi file.
Did not work, same result.
Then I chose the Ubuntu option and now I'm in Zorin OS on my computer without the USB.
But here's what I wanna ask. Will have to insert the USB and do this shtick everytime or what?
And is there a way to set this boot option as default.
Thanks for your help appreciate it.

1 Like

The live usb has Boot Repair app in System tools. It's not present once OS is installed. Give it a go.
This saved my backside once, but with Peppermint live usb. Can't remember if it was named 'boot repair' or 'rebuild mbr'...

You shouldn't need to boot from the usb every time. If the efi was installed on the hard drive, than that is what was needed.

The swap partition that I spoke of wasn't installed, which is strange because the along side method does create a swap partition. Either way, I'm glad you were able to get it going, even if it took a few more steps than I outlined. Try booting without the usb, it should boot. If it doesn't, you placed the efi on the usb or it didn't install to the drive. That is why I normally choose the partition, not the device. It doesn't always work correctly when you choose the device.

Yeah I tried rebooting but it did not work.
I had to insert the USB and choose Ubuntu again as boot device.

How is it that choosing Ubuntu works.
And how do I make this process permanent.
Or how do I fix this?

This tells me that you chose a different device than your Hard drive. You will have to look at the sizes in the partition window during installation. If it maxes out at the same size as your usb drive, that isn't the internal drive. I've outlined how to reinstall grub above. Make sure you choose the device that is your internal drive. Though there isn't a scroll bar, it is a scrollable window.