Can't boot with "Error: No such device: c3b9817..."

When I boot with Zorin OS 16 specified on the Grub screen, it fails to boot with the following error message:

エラー: no such device: c3b98178-e48... (ENGLISH: Error: no such device: c3b98178-e48...)
エラー: ディスク hd0,gpt5が見つかりません。(ENGLISH: Error: Disk hd0,gpt5 is not found.)
エラー: まずカーネルをロードする必要があります。(ENGLISH: Error: Kernel must be loaded first.)

続行するにはなにかキーを押してください... (ENGLISH: Press any key to continue...)

System Information:

Manufacturer: Mouse
Motherboard: X299-S01A
CPU: Intel(R) Core(TM) i9-10900X CPU @ 3.70GHz
GPU: NVIDIA GeForce RTX 3060

Wow, I've been looking at the user manual for that machine... that's a pretty awesome bit of kit... did you know it's got two BIOSs, and you can switch between them if one of them has settings that cause the machine to crash (or if a BIOS update fails and crashes that BIOS)?

Unfortunately, I don't see any hardware testing facility in the BIOS, so you'll have to boot the Zorin OS USB stick to check the drive. Looks like you've lost your boot sector, but there's no way to be certain until you test the drive.

So boot the Zorin OS USB stick, then open the Disks application, and click the 3-vertical-dots button at top-right, then select SMART Data & Self-Tests. I'd recommend doing the extended test.

1 Like

Thanks for the reply.

I tried SMART Data & Self-Tests.
The result returned "ディスクは正常です (ENGLISH: Disk is ok)".

Then it's got to be either a cabling problem, or a BIOS setting problem.

Shut down the machine, unplug the wall power, and reseat all the drive connections, especially the drive power... I've had the power connectors wiggle their way out before.

After that, ensure the BIOS drive settings are correct.

If that doesn't solve it, try swapping one drive's cable for another drive's cable... it might be one of the cables has gone bad.

Thanks for reply.

I reattached all the connectors connected to the PC,
The issue is still not resolved.

It sounds like grub is misconfigured.

Let me try finding a good guide for this...

Try these steps here, please:

1 Like

Thanks for the reply.

I see on that site that you are typing commands in a non-bootable situation,
but I don't know how to get into the command line in a non-bootable situation.

I would appreciate it if you could tell me.

It should be either repeatedly pressing or holding the shift key upon startup.

@Turtle11 @Aravisian
Thanks for the answer.

I tried to boot Zorin OS to try this method, but
I get the following error and cannot start Zorin OS.

GNU GRUB version 2.04

Minimal BASH-like line editing is supported. For the first world, TAB lists possible command completions.
TAB lists possible device or file terminations.


I fixed this before using Boot Repair, but it did not work this time.

Can you please type exit and then tap the enter key where it says grub> and relay the information it provides?

It sounds like you need these repairs:

Do you have a media with Super Grub2 lying around?

Thanks for reply.
This is the result of typing exit and pressing the Enter key.

I think this thread goes into the depth needed for this one:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.