Can't Change Resolution after using nomodeset

Hi everyone.
I'm a linux noob here. My dad asked me to change my old laptop's OS, so I landed on Zorin OS. At first after installation I got a black screen, then I searched for answers and followed [SOLVED] Black screen after install .
Now I got a new problem, I can't change resolution of my screen. I've tried to change using xrandr, but there's an error saying
xrandr: Failed to get size of gamma for output default.
I've been stuck with this for 5 days, I hope anyone can help me to solve this issue, thanks.

Resolution is stuck at 800x1280 77hz
(default 1280x800 60hz)

Changes to grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Laptop Specs: Lenovo ideapad MIIX 320-10icr
Intel Atom x5-Z8350 (4 cores, 4 threads, Base Freq 1.44Ghz)
Intel HD Graphics 400 (Haven't found any drivers)
Intel SoC platform
2GB DDR3L soldered
Storage 128GB eMMC flash memory on board

What is the terminal output for

sudo lshw -C video

May need to remove the nomodeset and find a different solution for that...

It displayed this

*-display UNCLAIMED
description: VGA compatible controller
product: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
vendor: Intel Cirporation
physical id: 2
version 36
width 64 bits
clock: 33Mhz
capabilities: pm msi vga_controller bus_master cap_list
configuration: latency=0
resources: memory:9000000-90ffffff memory:8000000-8fffffff ioport=1000(size=64) memory:c0000-dffff

Can you please boot to Grub Menu, then arrow key to boot with Recovery...
First thing in the Recovery menu to do is to enable networking.
Once enabled, back up to the recovery menu and arrow key down to Drop to Prompt.
Tap Enter key or ctrl+d, then open your grub file

sudo nano /etc/default/grub

Remove the nomodeset parameter and restore the line parameters to just "quiet spalsh"
Ctrl+x to exit, then the y key, then the enter key.

sudo update-grub

With that done, still in the terminal prompt, please run:

sudo apt update && sudo apt dist-upgrade

sudo apt install --reinstall xserver-xorg-video-intel

Once that is done, back out of the Recovery menu and proceed to normal boot and test.

Sorry, is the grub menu the system recovery menu? also how do you enable the networking?

Yes, if you do not see the grub menu at boot, you can tap the esc or tab key if using EFI or EFI /GPT boot. Or hold the Left Shift key if using Legacy (MBR) boot.
This should pull up the Grub Boot menu.

To enable networking is as easy as it sounds - which makes a lot more sense once you experience it. In the recovery menu, one of the listed options is "Enable Networking." Selecting it asks if you want net enabled, you say "yes"... and it is enabled.

I've got it into normal boot, black screen

forgot to tell, I've tried to watch youtube the other day and there's no audio.

Which previous kernels have you got installed on your machine?

Only Zorin Lite 16.2, just got it switched from windows 10 pro

Can you please show the output of
apt list --installed | grep linux-image

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-image-5.15.0-56-generic/focal-updates, focal-security, now 5.15.0-56.62~20.04.1 amd64 [installed, atuomatic]
linux-image-5.15.0-60-generic/focal-updates, focal-security, now 5.15.0-60.66~20.04.1 amd64 [installed, atuomatic]
linux-image-generic-hwe-20.04/focal-updates, focal-security, now 5.15.0-60.66~20.04.26 amd64 [installed, atuomatic]

ok and

uname -r

it's 5.15.0-60-generic

Good. Can you please roll back to the previous installed kernel:

Using this method:

From the Grub Menu, select to boot Zorin OS on 5.15.0-56. With that booted up instance, test.

linux-image-5.15.0-56-generic/focal-updates, focal-security, now 5.15.0-56.62~20.04.1 amd64 [installed, automatic]
linux-image-5.15.0-60-generic/focal-updates, focal-security, now 5.15.0-60.66~20.04.1 amd64 [installed, automatic]
linux-image-generic-hwe-20.04/focal-updates, focal-security, now 5.15.0-60.66~20.04.26 amd64 [installed, automatic]


also got a black screen, no difference

The driver is contained within the kernel, so we really need to saty within the kernel to try to solve both issues:
Black screen and no resolution change...
Let's try the OEM Linux kernel.

You can use Synaptic - search and install linux-image-5.10.0-1023-oem

Or install from terminal.
Ensure that you have removed the nomodeset parameter and run sudo update-grub prior to rebooting and testing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.