Can't connect my ethernet on zorin os

Hello everybody, I'm new to linux and I have issue with connecting my ethernet on zorin os. Actually, It worked properly before I update my apps through "software and updates" app. The funny thing is all the apps updated with the ethernet but after updates completed when I restart my pc my ethernet connection not working. In the Network settings the wired connect option is not visible. I've tried reset all the network settings but it's not working. If any one can help me with this issue. Thanks in advance.

Here is the output of sudo lshw -C network

Maybe your updates included a linux kernel update.
I would boot and select "Advanced Options for Zorin"
select a previous kernel version that is listed and boot that as a test.


Can you give us some details as to the network card installed?
Open a terminal and enter:

sudo lshw -C network

and post back the results please.

I am asking this after finding a solution for a realtek card here:

Looks like in the end it needed a complete reinstall - let's hope you don't have to!

1 Like

i have updated what you have asked.

I would try that patch given in that last link I posted as that mentioned msix issue.

I have found a solution. i find out that my network card was not being detected or was not properly configured. So I just did some research and make this happen. Follow those steps if you have the same problem.

step 1: lspci -knn | grep -i net A2 from the result note the kernel module name. it was r8169 for me.

step 2: sudo modprobe <your_module_name> voila it should fix it.

Thanks @swarfendor437 and @zabadabadoo for your assistance.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.