Can't Connect to NAS

I am using Zorin 16 and my NAS is a Dlink Sharecentre DNS320.
In Windows I have No trouble connecting/Mapping it, Without Any IP Address or Settings, Windows Sniffs it out and Maps it.
In Zorin , in the File Manager it does Show up But When I Click on it , I get some Error Message Saying it can't Connect, or words to that effect.
I have Asked the IT's at Zorin but it must be to hard for them as they did not respond.
Surely I am not alone with this problem, there must be many more people with the same problem.
You think the Tech's at Zorin would Promptly Fix it up.
It makes you wonder just how Little they know about fixing Problems with Their Operating System.
No wonder there are so many people that are faced with this problem and sadly have to go back to windows.

1 Like

There could be a number of problems here. Are you using Core, Light or Pro?

In the file manager, select: "Other Locations" (bottom left).

then enter the details for your NAS:

You should then be prompted for your NAS credentials, which you can opt to save.

If your NAS is older, it may be using a less secure SMB protocol. Google SMB versions.

Thank you Rmorris. We appreciate your willingness to assist.

@Sparks79 you may want to reconsider your remarks. There are two Zorin developers, not a room full of them, let alone a giant organization. They do take a little time to respond because they are constantly working on updates, improvements, new features, the next release and the forum. It's a lot for two people... and with several people just like you who expect immediate service emailing directly for issue resolutions.

Pro version offers installation assistance, service assistance beyond that is at the developers discretion... you may want to be a little more kind since treating people badly rarely ever results in getting what you want... let alone help here (we are all volunteers and assist at our discretion... it's not required).

Please read the Introduction to Hardware Support and FAQ before posting again. Further violation of forum policy will result in action.

Sorry if I appeared to be Complaining I have been looking for a fix for this problem for the last Two Years.
I have every bit of faith in the work you guys do there.
I have just cleaned out zorin for the umpteen dozen times and gone back to windows.
I think the next time I try to fix my problem , not connecting to my NAS, that I will install Zorin in a Virtual machine, because I don't have room for a permanent drive.
At least that will mean I don't have to setup a new installation of zorin after I test it.
My only reservations here is would a VM handle my networking/NAS Problem any differently than a Real HDD.
Now as for ( rmorris ) And I Quote ( If your NAS is older, it may be using a less secure SMB protocol ) , Well what Nags me there is the Fact that Everything Works in Windows Without any Change in Settings Or Protocol Input.
I am of the Opinion that This Problem Started back with Some Changes in UBUNTU a few versions Back. And Zorin is Based on Ubuntu so the problem has been Inherited by Zorin and to this day has not been fixed.
If Microsoft where having the same problem with their Networking, They would put out Fix for Pronto.
It just seems to be a bit strange that after Two Years Zorin has not even admitted they have a problem let alone try and fix it.
On the other side of the Fence Perhaps Ubuntu is the one that should be fixing it.???

Hi @Sparks79,

How did the advice I gave work out for you? I'm only guessing about the older version idea. I have to say that I hear your pain, I have had to learn a lot since moving from Windows. Just because something worked in Windows does not mean it will work in Linux. Windows by the way, is inherently less secure than Linux, and may not see the versions as a problem.

I don't think you will have any different an experience if you try in a virtual machine.

I have now re-read your post (and that of @337harvey) and suggest you might get better response if you posed your question in a less "complaining" manner.
I can see that you are frustrated - I've been there.

I don't believe there is a problem with "their operating system". You may need to look a little outside the computer and nearer the chair to see where the problem lies. Like I mentioned above - I have had to learn a lot from my move to Linux. 99% of the issues I came across were not because there was anything lacking in Linux, more that there was lack of knowledge on my part.

Keep asking questions & keep learning. I am sure you will solve this issue and at the same time, gain greater understanding of how it all "fits together".

I'm guessing you have access to the web admin front end on the NAS? How are the drives shared? Samba?FTP?NFS?. We are assuming Samba - but let's just check. Do you have samba tools installed on your Zorin machine?

Do let us know how you get on. I'm still new to all this as well, but if a Zoom call / screenshare / whatever remote technology you are comfortable with would help, just shout. (I'm in NZ & not sure where you are so we would need to think carefuly about timezones!).

Good luck.

1 Like

I had a similar problem with my NAS542 not connecting with my Zorin 16 Pro. My Win11 computer didnt have any problem and i also managed to connect my Amiga 4000 and AmigaOne X5000 with my NAS using samba FS.

I also didnt get my Samsung phone to connect with Zorin connect. I had another issue with bluetooth so i reinstalled my computer with latest Zorin OS iso and suddenly everything was working out of the box.

A reinstallation might be your friend :wink:

1 Like

Thanks to All that have Offered Advice and once again I am sorry if I sound aggressive, believe I am not.
I am back in windows just now and will set up zorin again today some time.
I am in Australia and Looking back from outside the chair I see some old grey headed Old B.
And I am Exactly that, I have been a Member of the Australian Order of Old B's since 1969 , ( https://www.aoob.com.au/ ).
Now , looking inside the nas as an admin, I can't see just what system it uses ie samba nfs or what ever.
In zorin I don't know if samba tools is installed, all I know is I certainly have not installed it.
I have been building windows computers for the last 30 years and I frequently Upgrade my Hardware.
The problem started after Zorin 15.3 when I was on older hardware.
Then when I upgraded my hardware Zorin 15.3 wouldn't install on it.
So I waited about a year or so for Zorin 16 , that's when I discovered the problem .
My System is Intel i9 1100k, Asus Z590A M/B, 64gb RAM, Three M.2 ( 980Pro 250gb), Water Cooled CPU, 80Plus P750GM PSU.
Running windows in Raid0.
In zorin file manager , where you connect to a network, I have tried their suggestions ( samba, ip, share name ) No Luck, Also tried all the other types their help suggests , like nfs etc.
It was clean sailing in Zorin 15 , I could see and work with files on my nas without any bother.
The problem kicked in from zorin 16 onwards.
I've had three different computers since then , so I know it's not hardware related.
If I can't see or work with files on my nas then it's all over for linux as far as I am concerned and back to windows, which is where I am now.
There are just to many other problems I just can't figure out.
Like with my brother printer/scanner/fax, in windows I could scan a document in, do some work on it , convert it to a file then send it on to a business client, but i can't do that in linux.
Then the big one , in windows i have all three HDD's set up as raid0 with windows on it ( and the speed ) well there's nothing like it.
But do you think i can install linux in a raid0 setup well think again.
The only one that i have found that can do it is fedora 35, but it is so hard to setup .
I haven't found any written instructions for raid0 setup with the os on it.
I fluked it one time, don't ask me how.
Once in with fedora 35, i was just getting used to it, then discovered the same problem, can't access my nas.
Switched back to windows and found all is working just fine and dandy .
I just wanted so hard to be able use linux for all the good reasons people praise about it.
But I just think I may have to face facts and admit it's just not for me.

D-link says:

The D-Link DNS line of NAS devices uses SMB v1 .0 and does not support SMB 2.x. -- support page

It also seems since Samba 4.11, support was dropped for NT1 (SMB1). Is it possible that this might be the reason you're experiencing trouble with that device? Have you tried a different network share from another device?

Hope this gets you closer to a solution.

1 Like

Thanks Very Much for that Info.
I must say it gives me a Clearer Picture now for what's going on.
I do realize that my Nas is old.
I had a more recent Synology Nas a short time ago, but didn't get round to testing it under Linux.
I had to get rid of it because it was able to Stream my Movies But wouldn't display the Subtitles.
I have some 2000 odd Movies in my library and because I am Death I Rely on Subtitles. So I have been Adding Subtitles to them for some time and am about 90% there.
From my testing it turns out that Movies with Embeded Subtitles are No Problem, But Add on Subtitles when going through a network cable to my Media Player at the TV End, Won't Display.
Anyway that's a story for a different Discussion.

I understand it might not be ideal, but it is possible to permanently burn subtitles into your movies using a short FFMPEG command in the terminal. This works if you have a separate SRT file or if the subtitles are part of the video file.

# example command for embedded subs
ffmpeg -i video.mkv -vf subtitles=video.mkv -c:v libx264 -tune film video-hardsubs.mp4

With the above command, it should take 4 to 6 minutes to create a subtitled copy of a 45 minute TV show. An added bonus is the subbed video file will retain chapter markings. The quality isn't affected noticeably either.

Example screenshot:

Please see the FFMPEG Wiki for more information on burning subtitles and encoding settings in case you would like to use different quality settings.

EDIT:

It is also possible to embed SRT files into MKV containers with FFMPEG.

# example command to embed SRT into MKV.
ffmpeg -i video.mkv -i subtitles.srt -c copy video-embededsubs.mkv

Hopefully that helps a little.

Thanks for that info on subtitles, I will look at your suggestions when I get time.
Must go and get some shut eye.
Cheers