Can't connect to Tor or even visit any VPN websites

I’m brand new to Linux, so if this is some kind of “rookie mistake” I apologize in advance, but I cannot figure out what the issue is.

I’m using Brave browser, and it will not connect with Tor like it’s supposed to when using private windows. I also cannot visit the Tor website or any VPN website, and I know it’s not Brave because the same thing happens with Firefox. When I try to visit any VPN website, I get this error:


Your connection is not private

Attackers might be trying to steal your information from [website url] (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_AUTHORITY_INVALID

ReloadHide advanced

[website url] normally uses encryption to protect your information. When Brave tried to connect to [website url] this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be [website url], or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Brave stopped the connection before any data was exchanged.

You cannot visit [website url] right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.


I inserted “[website url]” where it lists whatever website I’m trying to access, ExpressVPN, NordVPN, ProtonVPN, Tor, etc.

I’ve been searching and cannot seem to find a reason for this to be happening. I thought maybe it had to do with the clock not syncing, because there was an issue with the NTP client or whatever, but I fixed that and the time is now synchronized and this error is still happening.

I’d really appreciate any help you guys could give me.

Could you open a terminal by hitting ctrl+alt+t and pasting in the following:

sudo apt update

sudo apt full-upgrade

Are you using Zorin Lite or Zorin Core?

What method did you use to install Brave Browser?

I have had a look on Software Store and listing for Brave browser is a Snap. If that is how OP installed it then could maybe explain their woes.

Brave does not seem to be listed on Synaptic.

I think that eventually, Canonical will have to give in and stop Monopolizing Snaps and stop breaking their promises and FOSS.

After doing this, the first ended with “All packages are up to date.” and the second ended with
“0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.”

Zorin Lite, and I did install Brave through the Software Store.

I don’t know what this means (Snap vs. Synaptic) so excuse my ignorance, but as I said the same problem is happening on Firefox, which came with Zorin. Wouldn’t that indicate it’s not Brave that’s the problem?

The Upgrade terminal command was to ensure all your packages are up to date.

If all your browsers are doing it, it may be that your connection is being monitored by your ISP.
In which case, it is not Zorin or your computer.

Let’s keep looking, though. Do you get it with all webpages or just as select few?

Well, it turns out a family member had messed with our OpenDNS settings, without my knowledge, shortly before I installed Zorin, which is why I thought Zorin was the problem. They had unknowingly set it to a security level that blocked proxies/VPNs. I went in and changed the settings and that solved the problem.

Sorry for the trouble, guys.

2 Likes

Just a word of warning, using TOR without the TOR browser bundle poses a greater risk of de-anonymization. It’s best to use the Tor Browser Bundle unless you have a good reason not to or you understand the risks involved.