Can't connect to wi-fi / ethernet

Hello, so i was using Zorin for a while now and everything was just fine, but today my internet went down on one of its points

I have two, so lets call them point A (which can be accessed through wi-fi) and point B (which can be accessed through ethernet and wi-fi)

So, internet went down on point B (apparently a bug on the LAN routing, after changing it from to and then to again solved it) and i used wi-fi on point A;

So when i fixed the problem on point B, i tried using it on my Zorin (it is working ATM on my phone, some windows machines, smart tvs etc) but it didn't connected to it. I couldn't connect it to in any way!

On the wired connections pannel it shows that it is trying to connect - but then shows the cable is disconnected right after; on the wi-fi pannel it tries to connect, but never does. It loads forever!

So, i tried restaring my pc, device, wifi-router, tried a bunch of commands i found online (will post it below)

I tried to force Zorin to forget the wi-fi connection and try to connect to it again, but no luck

Well if it helps anything, here are some commands i tried:

sudo service network-manager restart (did restart my network but even so, point B is unreacheable)

Tried editing etc/network/interfaces but it is empty

Please help me :frowning:

Here is the output of my ifconfig command:

enp59s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500

inet6 fe80::a5e2:1b05:a290:df07 prefixlen 64 scopeid 0x20<link>

ether 54:bf:64:25:3c:0b txqueuelen 1000 (Ethernet)

RX packets 0 bytes 0 (0.0 B)

RX errors 0 dropped 0 overruns 0 frame 0

TX packets 22 bytes 7590 (7.5 KB)

TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

device interrupt 17

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536

inet netmask

inet6 ::1 prefixlen 128 scopeid 0x10<host>

loop txqueuelen 1000 (Loopback Local)

RX packets 8178 bytes 855562 (855.5 KB)

RX errors 0 dropped 0 overruns 0 frame 0

TX packets 8178 bytes 855562 (855.5 KB)

TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp60s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500

inet netmask broadcast

inet6 fe80::82e6:ea2a:9f4d:bd50 prefixlen 64 scopeid 0x20<link>

ether 74:40:bb:f3:79:73 txqueuelen 1000 (Ethernet)

RX packets 31765 bytes 26447351 (26.4 MB)

RX errors 0 dropped 0 overruns 0 frame 0

TX packets 25493 bytes 4784087 (4.7 MB)

TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

What is the output from the terminal for:

inxi -n


sudo lshw -c network

sudo lshw -c network:

descrição: Ethernet interface
produto: Killer E2400 Gigabit Ethernet Controller
fabricante: Qualcomm Atheros
ID físico: 0
informações do barramento: pci@0000:3b:00.0
nome lógico: enp59s0
versão: 10
serial: 54:bf:64:25:3c:0b
capacidade: 1Gbit/s
largura: 64 bits
clock: 33MHz
capacidades: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuração: autonegotiation=on broadcast=yes driver=alx driverversion=5.13.0-27-generic latency=0 link=no multicast=yes port=twisted pair
recursos: irq:17 memória:ed400000-ed43ffff porta de E/S:3000(tamanho=128)
descrição: Interface sem fio
produto: QCA6174 802.11ac Wireless Network Adapter
fabricante: Qualcomm Atheros
ID físico: 0
informações do barramento: pci@0000:3c:00.0
nome lógico: wlp60s0
versão: 32
serial: 74:40:bb:f3:79:73
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuração: broadcast=yes driver=ath10k_pci driverversion=5.13.0-27-generic firmware=WLAN.RM.4.4.1-00140-QCARMSWPZ-1 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
recursos: irq:135 memória:ed200000-ed3fffff

This chip is notorious on Linux. Most users that have that chip buy an inexpensive Wifi USB dongle and use it instead.
Qualcomm is a bit slap-dash about providing the proper firmware to Linux (A bit like how AMD is...) resulting in the products usually working, but not always and painful to troubleshoot when they don't.

You might check if there are any errors with:

dmesg | grep ath10k_pci

If nothing appears, then there are none logged.

1 Like

Here is the output of the command:
[ 10.154799] ath10k_pci 0000:3c:00.0: enabling device (0000 -> 0002)
[ 10.164743] ath10k_pci 0000:3c:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 10.472530] ath10k_pci 0000:3c:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1028:0310
[ 10.472534] ath10k_pci 0000:3c:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 10.473940] ath10k_pci 0000:3c:00.0: firmware ver WLAN.RM.4.4.1-00140-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 29eb8ca1
[ 10.540780] ath10k_pci 0000:3c:00.0: board_file api 2 bmi_id N/A crc32 4ac0889b
[ 10.697394] ath10k_pci 0000:3c:00.0: htt-ver 3.60 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[ 11.818999] ath10k_pci 0000:3c:00.0 wlp60s0: renamed from wlan0

It looks like you need some firmware.

Once you have installed the Firmware package, please hard reboot the computer to test.

You ain't kidding Aravisian. Exactly what I had to do.

HaroldBeyer, if you go that route, just make sure you get one compatible with Linux. Quite a few say they are, but are not. Unless you want to do a bunch of other things to get it to work.

Thanks, I hope this will help me, I got some important work to take care-off and the wifi connection was not responding. I worked as vpn reseller and need to get connected with the server all the time.

FYI. This thread shows a selection of wifi dongles that work. In quest for Linux compatible WiFi

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.