Can't delete VueScan file

Uninstalled VueScan but software store keeps saying I need to update this:

How can I delete it? My Canon mf733CDW printer won't scan from feeder on my Zorin Core 16.2 running on mid 2010 Mac desktop. Was working, now not. Scanner works on platen, just not on feeder. Also works fine on my 2015 Lenovo Carbon X1 3rd gen running same Zorin OS. Yes, I have installed Canon software for Linux. Printing works fine on both machines.

Any suggestions?


You may need to install VueScan again, then follow::

To remove VueScan on macOS or Linux, use the “Help | Remove VueScan” command while running VueScan.

OK, thanks for the reply.

OK. I did as you suggested, and it appears to have worked as you said it would.

I had hoped that removing that file would allow my printer to scan from the feeder. Alas . . . it didn't help. Any suggestions?

What happens is that the scanner makes the usual sounds, but at the end of the process, I get the message "Failed to scan. Unable to connect to scanner."

Works fine from the flatbed.


Printers and Scanners are probably my weakest subject. Please be patient and allow for others who have better knowledge to weigh in, as well.
Can you please list your Make and Model?

In the meanitime, you might remove the existing software package that comes defualt and use an OpenSuse alternative that is reported to work better:

sudo apt remove --purge ippusbxd

and install

That link is from Debian SId repo, so please relay if you get any dependency errors.

sudo apt install xsane sane sane-airscan

Opening the settings for your scanner, before testing if you can scan, please be sure to switch to the alternatives you installed above. Otherwise, you may think it is still not working.

Thanks for the reply. My printer/scanner is a Canon Color ImageClass MF733Cdw. I'll give your suggestions a try.

As I mentioned earlier, everything works fine on my Zorin Core 16.2 install on my Lenovo Carbon X1 gen 3 laptop.


Ok, good. Not HP, then. Yes, we will start with the above tips.

Yes and on a MacBook, it is unsurprising that it may take more jiggling...

Thanks Aravisian. Haven't had a chance to try your suggestions, but I appreciate you.

Also, turns out that VueScan file was not removed. Software center offered to update it today.

How do I remove VueScan? | VueScan Support.

To remove VueScan 9.5.85 or earlier on Linux, just delete it - no other files are installed.

That applies to that version or earlier - what about later?
Can you check if it is installed with Snap

snap list

or Flatpak

flatpak list

as well?

Ahhh, here it is:

VueScan… …rick.VueScan.Locale stable flathub system

Now what? :slight_smile:

1 Like

Let's try

flatpak uninstall vuescan

Got error: No installed refs found for Vuescan

Should I install again then uninstall this way?

I haven't tried your other suggestions for getting my printer to scan properly. I don't really care if that one Vuescan file sits there as long as I can get my scanner to work.

Is there a way to find where that one file is located and simply delete it?

BTW, I'm learning a lot, so even if this isn't solved, it's a great experience. Fortunately my scanner works using my Lenovo laptop/Zorin and my Macbook Air with latest Mac OS, so I have options.


I am uncertain on this. Flatpak packages work a little differently. I cannot be surprised if it is a flatpak and is in fact uninstalled / removed... yet Gnome Software still try to update it, either.

We can continue there and return to the rebellious VueScan later.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.