Cant get any game controller to work correctly

I have tried to connect both a xbox one s and ps5 dualshock controller to my computer, the controllers pair as expected but the buttons are not recognized correctly X is recognized as Y on the xbox and the right thumbstick is stuck going left on the ps5, the dpad is not recognized on either its not related to a drifting issue as both work fine on my steam deck, i have tried to install xpadneo and xboxdrv to no change. im still not sure if its because i did something wrong or it just didnt work, im still very new to linux. I would appreciate any help in getting either my xbox or ps5 controller to work.

I use xpadneo and never had any issues.
I would actually check your Bluetooth drivers. Ensure that the controllers are Fully Charged.
Reinstall xpadneo (and remove xboxdrv in case it is conflicting with its config files with xpadneo), then reboot and test the controllers.

@FatManJerry. Can you please edit your forum profile, to show which edition (Pro, Core, Lite etc) of ZorinOS you have installed. That will help us help you in the future. Thanks.

This 1000x.

sudo apt install dkms linux-headers-`uname -r`

git clone

cd xpadneo

sudo ./

Not sure if it is required but I would restart the computer then try the Xbox controller

I never have gone through the trouble trying to get the Dualsense working correctly. It seems to have a touch of lag when I have tried it.

1 Like

I am not sure about Wireless as I am new as well. I have a dragon, something controller. I had the install Xboxdrv for my controller to work even though it is not an Xbox controller. Not all my games worked this way as some of my games either had the configuration wrong or did not detect it ( Grim Dawn as an example ) So I use Lutris and it works fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.