Can't get beyond the Installation menu

I am trying to install ZorinOS education alongside my windows 10 on my Levovo IdeaPad Gaming Amd GtX 1650 UEFI version

I created a USB live disc, I get the screen to choose the try and install ZorinOS, but if I click on any of the options, the screen just goes black and nothing happens even after an hour.

I have even tried the nomodeset option, but that doesn't help either

Please try #1 here: Before you install
It also may help to check #2-#5 on that list.

I tried every step, the SHA key matches and everything but it still won't go beyond the first menu. I tried live booting Elementary OS and that worked, so I don't think there's an issue with the pen drive too
Will probably use a VM or WSL

@Suhel Which version and flavour of Zorin are you using. e.g. Z15.3 Core/Lite or maybe Z16Core Beta?

@zabadabadoo ZorinOS 15.3 core 64

So are only getting as far as the choice between Try Zorin and Install Zorin that comes up on the Zorin Live USB.

If you have already tried all the advice covered in the link provodided by @carmar above, then I can't think of much else to try myself right now.