Can't get Ceasar 4 to work

I know this is an old game, but I like it. I have tried the winetricks, protontricks, and did everything I found online different forums. It worked for a couple of days, but now it doesn't and I have tried to do it all again. I get a runtime error that has something to do with the Registerdll.bat file needing a higher permission.

HI, When I used to run Windows games on Zorin I would do this.

  1. If from a CD, I would look at what the label was showing on the Desktop, i.e., name label underneath icon of CD.

  2. I would browse the fake C:\ drive under .wine in your home folder and create a new folder with the same name as the CD.

  3. I would copy everything from the CD into the newly created folder on the fake C:\ drive.

  4. I would select all the folders and under Properties went to Permissions and check mark "Allow executing as a Program".

  5. I would then run the setup.exe and it would run. This worked for me for Blackhawk down.

  6. If a game needed the CD to be present while playing the game, this would involve creating a particular file using K3b to create a fake CD and run that first to launch the game.

It's not on CD, it's through Steam which is why I was surprised it didn't work. I had to do the same thing with Windows. Much easier though. Not sure what to do now.

I have played this game on Steam before, though quite a while ago. I see no reason why it would stop working now? I don't recall doing anything special but perhaps you need to enable or disable something regarding the compatibility with Linux.

I had to go into the local files and reset the user permission for the dll files to run. Otherwise it gives a runtime error. I have tried to do with Wine, but it says that this a 32 bit program and it no linger supported. I tried portproton, it did nothing at all. I tried renaming the wine file to create a 32bit file, but that did nothing either. The very first time I tried it worked. Then I did a dual boot with another Linus OS (Mint) just to compare them and now it won't work at all.
This is one of the reasons I have been so slow to go to Linux, it almost requires you have some programming knowledge. I am at a complete lost as to what to do.

I just realized that I only have Caesar III, not IV, so I can't say how well this runs. You can check this website to see how the compatibility is for each game:

For Caesar III the compatibility is ranked as "gold", meaning that it runs smoothly, while Caesar IV gets a "silver", which requires some tweaking with settings. What those tweaks are exactly I have no idea, but there is a discussion board right there when you search for the game where people share some experiences. Hopefully that will help.

It's important to understand that most commercial software is designed to run in a particular platform. Since the goal for them is to make money, that platform is going to be the one with the bigger market share which is of course Windows. The smaller the market share, the less incentive there is for these companies to develop native solutions for other operating systems, compatibility layers or even make the source code available so that the community can take over that task. This is especially true for video games.

Funny enough, I don't see many people complaining that games don't run on MacOS even though Apple has a much bigger market share and a budget that is orders of magnitude larger than there is available for Linux.