Can't get in Bios after installation of Zorin OS Core 17.1

Hello, i recently tested Zorin OS and i liked it very much (1st time using linux). So i decided to install at an old Samsung laptop my client has. Because he can't work, now wants back the old windows 7. I try to format with external usb but i couldn't because the usb is not available when i press F10 to select boot device. I also tried to get in bios with F2 but i couldn't either. How can i install windows again? Why my bios is not working anymore?

Hi and welcome.
Sadly Samsung is one of the worst producers of Notebooks. When you installed Zorin did you delete the recovery partition? From memory you should be able to reinstall to factory defaults by pressing F4 during boot time. If not you may have to send it away for repair unless someone else can offer a better solution. I feel for you. Samsung, unlike other notebook manufacturers never have BIOS updates, so I would always recommend you avoid Samsung at all costs.

1 Like

Yes, unfortunately I deleted all partitions. :thinking:

Welcome to the Forum!

Okay, try the following (it sounds maybe a bit stupid, but safed me a couple Times):
You turn the Laptop off. Not Sleep Mode or something like that; complete off. Then You push the Power Button to turn on and immediately after pushing the Power Button press the F2 Button. Press it fast again and again and again.

Maybe something here: uefi - I can’t access the BIOS setup using F2 key on Samsung NP270E5V laptop - Super User

1 Like

Another option if you are confident enough to do this is to remove the base cover and remove the CMOS battery, leave it out for 30 seconds, replace battery, put case back on and reboot.

Seeing as F10 works to get you the list of boot options, could you try that again and see if there's an option in the list to enter BIOS / UEFI? I have seen this on several different systems.

If not, try installing another USB stick with Ventoy and then copy your Windows ISO on it - do not burn the Windows ISO, just copy it across like any other file. If you can boot into that stick from the F10 list, you can either go straight into the Windows installer, or otherwise you can hit one of the F-keys (I forgot which, I think F4 or F5) at the Ventoy screen to get a list of other options which includes rebooting into BIOS / UEFI.

Also, this has caught me out before, but are you trying to use a 64bit Windows ISO? It could be the laptop only supports booting in 32bit (even if the CPU is 64bit!)

Finally, there should be a way to make grub display even if there's only one linux OS installed, and the grub menu should have a BIOS / UEFI options. Spam / hold either the Shift or Esc keys, depending on if you have BIOS or UEFI.

1 Like

I remove the CMOS battery and know can't boot also the HDD with Zorin OS 17.1 :laughing:

The problem must be BIOS. Because when press the power on button appears Samsung logo and the F2 for setup and F4 for Recovery but reboots like it cant find bootable device

So does spamming F2 (like a manic woodpecker) on startup get you into BIOS now?

4 Likes

Haha! Good Description!

No Bios Samsung logo with F2 & F4 below but even i don't press button or press "like a maniac woodpecker" the same time screens black and restart loop again and again...

You did put the battery back in didn't you?

Yes i did. Also replaced it with a new one. I think that the bios is corrupted or something change when install Zorin OS (because when i tried to install windows again i couldn't get in Bios with F2 and with F9, boot options, the usb with windows wasn't available). After that i removed the CMOS battery to returned BIOS settings but when i try to boot from usb or the internal hdd (the one that have Zorin OS), the laptop couldn't find a bootable device and loops on Samsung logo.

It would appear it has become e-waste. Based on dealing with Samsung notebooks at work, I would never buy a Samsung Notebook. Remember the Meltdown debacle by Intel? They (Intel) provided a tool to check if processors were susceptible to the meltdown flaw and it was down to manufacturers providing a BIOS update, and of course, Samsung never did. They don't even provide basic BIOS updates. I would advise your client that the notebook has died. Hardware does not last forever. There are plenty of second-hand notebooks on eBay.