Can't get rid of a program

I installed a program from its source code; since it was defective, I deleted most of its folders hoping to be able to uninstall it that way (I know, I'm a noob). The makefile was in one of those folders; now I can't seem to find a way of getting rid of it :sweat_smile:

Hi and welcome to the forum :slight_smile:

The correct way to remove application is issuing the following command in terminal:
sudo apt remove --purge package-name

Refer to the tutorial on this forum.

Since you have deleted some folders this command may not work.
If that is the case, you have to reinstall application to remove it.


Also, if you are willing to share what the program was, we can probably look at the source and figure out where it installed its components and help you dig it out.


It's Dolphin emulator: GitHub - dolphin-emu/dolphin: Dolphin is a GameCube / Wii emulator, allowing you to play games for these two platforms on PC with improvements.

Most of the files contained within are Windows files (.dll shared object files and .exe executable)
Did you install this on Wine? Or did you install it for Linux as per the instructions? (I know you used Make which means Linux, but I want to be sure before telling you how to delete stuff).

1 Like

No, I didn't install it on Wine; should I? by the way, thank you and @FrenchPress for your replies


I wouldn't. Wine can be useful when it is necessary, but if you have the option to use a program natively - take that option.
Your question implies, however, that you would prefer to not remove the program; you only considered doing so because it was not working.
Would you prefer to keep the program and to try to make it work?


Yes, I'd really like to make it work; the matter is that there are lots of files missing now because I deleted folders. I'm going to install it from source again, as FrenchPress suggested. Would that conflict with the remaining files from the previous installation?

No, make would replace files as needed.

The build page comes with an additional Linux Guide:

First, open a terminal and run the following command to install any needed dependencies. Zorin OS comes with much of this already, but let;s Be Sure:

sudo apt install --no-install-recommends ca-certificates qtbase5-dev qtbase5-private-dev git cmake make gcc g++ pkg-config libavcodec-dev libavformat-dev libavutil-dev libswscale-dev libxi-dev libxrandr-dev libudev-dev libevdev-dev libsfml-dev libminiupnpc-dev libmbedtls-dev libcurl4-openssl-dev libhidapi-dev libsystemd-dev libbluetooth-dev libasound2-dev libpulse-dev libpugixml-dev libbz2-dev libzstd-dev liblzo2-dev libpng-dev libusb-1.0-0-dev gettext

All you need to do is highlight the text and paste it into terminal.
Use git to pull the package and clone it in your Home Folder:

git clone GitHub - dolphin-emu/dolphin: Dolphin is a GameCube / Wii emulator, allowing you to play games for these two platforms on PC with improvements. dolphin-emu

Change Directory (cd) into the new directory you just cloned:

cd ./dolphin-emu

Clone submodules:

git submodule update --init

Use most recent version:

git checkout tags/5.0


mkdir Build && cd Build

cmake ..

At this point, we learn that the Program is installed in /usr/bin/ - You probably needed to enter that directory and enter your password to have removed it;)

make -j$(nproc)

sudo make install

If it completes with no errors, try launching it from the terminal with


To test it.

This page also notes:

Most of the time, any problems in the build process are due to user error. It's understandable, it is a complicated process and can be quite daunting for a first timer. But sometimes even with everything right, triple checked, and it's still not working. It's rare, but sometimes a build will just be bugged. But many of Dolphin devs are Linux users, so just wait a day or so, and it will be sorted out. If you are trying on Ubuntu 16.04, it is tested and working now

And links to their User Forum that may be more helpful to you:


Thank you so much, I'll try this right away and let you know if it worked :grinning_face_with_smiling_eyes:


It didn't work :frowning_face: I ended up reinstalling Zorin; it turns out that Dolphin's newer releases have issues with my hardware and with Linux itself. Thank you anyway! :heart:


Well, just recall that the Program itself is supposed to be installed in /usr/bin/ if you decide to delete files again. :wink: :stuck_out_tongue:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.