Can't install any software, store no longer working

I experience a new problem, which was definitly not so before. I can't install any software. If I click on any "product" in the store, I get only the "spinning wheel in the middle of the page.

That happens also, if I download something from the web and try to install it. Latest example:

I click the link, a window opens and ask for permission to open xdg-open and I am coming again in the store with a dark page an the spinning wheel.

I tried it with brave also and all the same. Any idea what I have to check and / or change?

Kindest regards,

killall gnome-software

rm -rf ~/.cache/gnome-software

sudo apt install --reinstall gnome-software -y

Gnome Software is in use to install .deb packages from the web.
I use Gdebi to install .deb pacakges if using a GUI manager for it.

sudo apt install gdebi

1 Like

will try that later when back at the notebook. When I install your last software recommendation, how do the system / or I select WHICH software is responsible for installing at the end? Don‘t they conflicts each other?

You can right click and choose which installation app to use. Or, right click and select the properties, then the "open with" tab. At the lower right you can see a button to set your selection as default.

They won't. Gdebi is its own software and does not rely on the Gnome-Software application at all.

@Aravisian I tried your commands, but as soon as I use to install something, the system runs into that error message:

I suppose I have done something wrong trying to install the spotify app manually and messed something in the system.

I tried to find the /etc/... location on my drive but can't find it. Can you please be so kind and give me some more instructions to clean that up?

I inspected the repository list as in your guide but couldn't also find anything related to spotify. Last action I took was to try to copy that command:

beginning with curl and, if I remember right, I got an error in terminal because of the linebreak(?).. don't know exactly

And in addition, I got a message to update an extension, and after trying to do so, I run into that:

red explanation mark in taskbar, "an error occured please run paket manager..."

Kindest regards

Don't worry. This is an easy thing to fix once you have encountered it more than the very first time.
Elevate your terminal to root by:

sudo -i

Now, launch your file manager from within that elevated terminal to elevate your file manager to root:

nautilus

Tap "Other locations" in the left pane. Then "Computer" in the right pane.
You are Now In Root.
You should see the directory for etc
Open it, then go to apt then Right Click on sources.list and choose Open With > Text editor
With it open in the Gedit text editor, tap ctrl+F for the Find function.
Paste in
deb http://repository.spotify.com
Or just
spotify
Find the line that added deb http://repository.spotify.com to the list and remove that one entire line for Spotify.
Save the file.
Open a New terminal window and test that all is well with:

sudo apt update

If all is well, close the text editor, elevated Nautilus File Manager and the Elevated terminal.

It sounds like the line curl -sS https://download.spotify.com/debian/pubkey_0D811D58.gpg | sudo apt-key add -
blended in with
echo "deb http://repository.spotify.com stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list
In other words, both separate commands were put into the terminal as one command. They must be separate:
To add the repo KEY, paste in:
curl -sS https://download.spotify.com/debian/pubkey_0D811D58.gpg | sudo apt-key add -

Tap the enter key. Once done, add the repository:
echo "deb http://repository.spotify.com stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list
Then tap enter.

Now check again in the terminal:

sudo apt update

tried, but there is nothing spotify related in that file - and yes, I thought it was ONE command and copy pasted it as one into terminal.

I FOUND something spotify related in another directory .d and trashed that file named spotify.list completly.

Now I was able to run your given commands and reinstalled respectivly installed the new software.

Will take a moment if the rest works...

1 Like

That would be /etc/apt/sources.list.d/spotify.list

correct

@Aravisian I thank you very much for your kind and honest support. I now was able to run thru all of your commands and installed everything and the native spotify client. As far as I can see for now, no other errors popped up since then.

One little difference occured while copying the given commands from you: The pubkey you gave run into an error but I interchanged it with the one from the spotify page and then everything was fine.

That was my first operation at the open heart of that new and for me unknown operating system and again, I can't thank you enough not only for helping me to solve the problem but more to get in deeper touch with this uncharted territory...

1 Like

Thanks for fixing that. I looked up the pubkey and must have gotten an outdated one.

A few times of it and you will find you remember locations in root as easily as you remember your files and folders in home directory.:wink:

1 Like