Can't install git

help, can't install git.

You don't need an additional repository, git is available in the default ones. This should do it:

sudo apt install git
1 Like

Following @zenzen's advice, first remove the repository that you added.

sudo add-apt-repository --remove ppa:git-core/ppa

Then run

sudo apt --fix-broken install

Then run the command zenzen provided.

I followed your instructions and those from @zenzen, but still get the same error

Launch Software & Updates and ensure that the top four options are checked -

  • canonical-supported free
  • Community maintained free
  • Proprietary drivers for devices (restricted)
  • Software restricted by copyright... (multivere)

That last one is the important one.
Once those are checked, close the app and let it refresh when it asks.
In terminal run

sudo apt update && sudo apt upgrade

Then

sudo apt install git

2 Likes

this worked. I had the first one unchecked. should I also check "source code"?
thanks for helping

1 Like

No, the source code options are unnecessary and can all be left Unchecked (Including those in the Other Software tab.)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.