Can't install Microsoft Edge

I get a 404 error when I try to install it via Software.

It's a server error as the error message shows:

You can still go to Microsoft's website and download from there. Scroll down a bit and click on the link that says "Download for Linux (.deb)"

1 Like

Moved to #general-help.

Thanks! Downloading and installing from Microsoft's website worked. I do think it would be good if it worked via Software as well since many people migrating from Windows are Edge users and it would be the easiest solution to retain bookmarks etc. (even though there are other ways).

1 Like

I just tried again and it's working fine now. It was probably some lag communicating the new available version to the flatpak store. If you compare the screenshot of the error from my post above with what's currently showing, you can see there's a mismatch:

sc1

To be clear, this is not an issue with ZorinOS but with the Flatpak store, and I would even argue with Microsoft for removing the previous release without giving proper time to update all repositories.
Although I admit that I'm not very familiar with how Flatpak handles their packages (perhaps they only allow one version, namely the latest available, to be downloaded which would be... well, bad).

In any case, glad it's all working for you.

Flathub lag is actually not unusual...