Can't install Zorin OS 17.1 Pro

Hello,

I just bought the pro version for Zorin Os 17.1 and I can't install it on my new laptop Lenovo Yoga Pro 9 16IMH9 for the life of me.
I made 4 bootable USB devices (thought the usb drives might be damaged?) using the official instructions via balenaEtcher, I tried all 3 installation options:

  1. Try or install Zorin OS
  2. Same but with Safe Graphics
  3. Same but with Newer Nvidia Cards.

Regardless of the option I chose, the screen stays black, nothing else happens.
This laptop has an RTX 4070 GPU and an Intel Ultra 9 185H CPU, I tried other linux distributions and they all work (Ubuntu and Linux Mint).

Any idea of what else I could try ?
Also, I ran the checksum and it checks out and did all the steps mentioned here:

So SafeBoot / TPM and all that are disabled.

Thanks in advance!
Serge

Short update:
I thought I'd give another version a try, so made a bootable Zorin 16.3 Core. This one boots fine and I can perform the installation. But as soon as I reboot after the installation completes, the screen stays black and there's just a white dot or small bar at the top left side of the screen, it doesn't blink or do anything, just stays like that and nothing else happens....

Is it driver 550? You may try a lower version to see if it helps.

EDIT: Can you get into TTY/CLI (ctrl+alt+F1 to F6)?

I could get into TTY/CLI, seems I'm using Nvidia Driver 535, and shortly after typing in "nvidia-smi" to get the GPU/driver details I was spammed with the same message, please see the attached photos:


Forgot to mention that this happens in Zorin OS 16.3 Core, which I've just installed in order to determine whether my USB drives work or not, in the end I still intend to use the 17.3 Pro version - which can't even be installed.

When we fix the driver issue, you can upgrade 16 to 17 after that. Lets try install a newer driver than 535.

sudo apt install nvidia-driver-550

Also give us the out of

sudo install inxi
inxi -Ga