Can't login to my computer

After I forgot my password I started using GRUB and it showed me that my password doesn't match my keyring. I tried changing keyring using seahorse but I found nothing there.
Then I tried uninstalling gnome-keyring to install it once again, but somehow it got uninstalled maybe and then my laptop restarted and I can't login to my laptop since then. I entered my user name and password but it still is stucked in the terminal only as shown in the image.

Please anyone help me. I have important stuffs in my laptop and I don't know how to get out of it!

From pages 179 to 181 of the unofficial manual I wrote for Zorin 15:

"2. The Login Loop – You try to login but after you enter your
password you are back to where you started!
[UPDATE 20.01.2020 - Have found another potential cause to this problem -
corrupt files. I booted a recent install of Zorin Education 15.1 on works
Notebook and had login loop. Started in Advanced | Safe mode and ran FSCK -
it could not run automatically, stated it would need to run manually.
So at the prompt you type:

fsck /dev/sda1

This is assuming there is only one hard drive in the machine - you would of
course put the device label according to which drive Zorin is on.
fsck runs and reports file errors in inodes and asks if you want to repair - well
yes, you do obviously! Enter 'y' for any other prompts - it will tell you when you
have finished. On completion of the task you will be returned to the safe mode
options menu - don't select 'RESUME' - turn off the machine and power up -
problem solved! :smiley: ]
The 'de facto' solution...
Is usually is to boot into advanced | recovery mode then from the recovery
memory launch 'root' (terminal) then enter:

mount -n -o remount,rw /

then press Enter.

passwd your_username

then enter new password, shutdown and

If this does not work, and if you have Timeshift installed (can't remember if
Zorin includes this) then boot from live DVD/memory stick and point to where
the snapshots are held and see if that works. If it doesn't try one of the
following 3 options (acknowledgements to
loop.html? )

"Method #1 Fix Ubuntu login screen loop
The first is quite simple. The file is located under the current user's home
directory. All you will have to do is change the owner of .Xauthority file.

Step 1 - At login time, use Ctrl+Alt+F3 to switch and access the command line
interface mode.

Step 2 - Login into the shell using your username and your password. In this
case, username will be your username you set when you installed Ubuntu.

Step 3 - Once logged in, now run ls -lah to view list directory contents. Look for
the line that ends with .Xauthority

# ls -lah -rw------- 1 root root 53 Nov 29 10:19 .Xauthority

Step 4 - You need to do chown. Type and run the following command :

['sudo' if not currently 'root'] chown username:username

Now reboot and see if you can log in - if not:

Step 5 - If it does not work, try renaming.

mv .Xauthority .Xauthority.bak

Now reboot and try re-logging in.

Method #2 How to Fix Ubuntu login screen loop

Step 1 - Run

ls -ld /tmp

Check for the first 10 letters in the left: they should
read exactly so: drwxrwxrwt

# ls -ld /tmp
drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Step 2 - You may need to changing permission. Run the command below :

sudo chmod a+wt /tmp

Method #3 How to Fix Ubuntu login screen loop
If even both did not work for you, try the last one! Please make sure you are
connected to active internet. Check this out!

Step 1 - Uninstall and reinstall Ubuntu lightdm. Run the following :

sudo apt-get purge lightdm
sudo apt-get install lightdm
dpkg-reconfigure lightdm

Step 2 - Once reconfigured, now reboot."

[I have modified the instructions as it is not clear at which point you become 'root' using the 'sudo' command - if the last element of a terminal prompt is '#' then you are in the terminal as 'root' with elevated privileges. If the last element of the command prompt is '$' you are a standard user, and not 'root'. I have written this tutorial experiencing just this and used Method 1 which solved the issue for me in FerenOS]


First of all, I appreciate your help.
The first two methods didn't work for me as there was no .Xauthority file that I could find and same with the second method, there was not exact file as you mentioned. But I resorted to installing Lightdm and it worked and now I'm able to see my login screen, but now the problem is I can't enter password to login as I can't find any field to do so. Now too I'm stuck in a way :joy:

That image shows an Ubuntu, not Zorin Backdrop.

It also shows a Broken Installation of LightDM, it is not working properly.

Have you isntalled Ubuntu, Unity or other desktops on Zorin OS? Or installed supposed Helper Apps like Grub Customizer?

1 Like

No I haven't done anything like that.
And now that I couldn't login, I pressed Alt+Ctrl+F4 and now its again back to the command prompt as earlier.
Is there any way of re-installing the os without losing my data?

Not really - But I highly recommend a reinstall. That DM screen looks very broken to me. Something has gone wrong.

IF this was Me.... I would physically disconnect the drive and connect the drive to another Linux running computer. Once connected and mounted, access your personal data and save it in a Safe Place.

Once you have triple checked your personal files are all backed up- reinstall Zorin OS with the Wipe and Install option - Do Not Encrypt The Drive.


I remember here somewhere was solutions edit grub and you login as root. Here is link guide Linux Guide/Reset a forgotten root password - Wikibooks, open books for an open world

Just when I considered for a new installation of an OS, it started to show the fields. But now the password doesn't match!

In my mind, this is only confirmation that considering a fresh reinstall is the way to go.

Yeah I understand that completely. But I really do have very precious files of mine and I see no way to recover that as I can't take out the drive and store the files somewhere, none of my friends here uses Linux :weary:

I hope you can understand my pain and find any alternate solutions to these!

I have the problem with my Zorin. I created a live usb pendrive and copy all files from home folder or any another important stuff. I put second pendrive 128gb and copy all that files what i need.

1 Like

The problem is I'm stuck on the login screen and command prompt screen.
How would I copy files from there? Is it possible?

I understand you have only one laptop and no pendrive to create live usb?

I do have a pendrive

I mean if you have a pendrive and some a second hardware pc with internet then you can download live iso linux and install that on pendrive.

@Levi ,
This forum seeks to be a welcoming and helpful place where all users can benefit from each others experiences and knowledge.

There are times where the lines can become blurred, between being helpful and being a hinder to solving an issue.
You certainly need to access and save/backup/restore your personal files.

Sometimes thing go wrong for good people. It does not always take a poor choice or a mistake for misfortune to strike anyone.
However, for the integrity of this forum, as we seek to be helpful and give benefit of the doubt, it can become problematic to help a person to access files to which their password does not work on a machine that they do not own.

Assuredly, you have a lot of trust within your company as they have entrusted this machine to you. Is it an option to seek help from your company I.T. dept. to salvage your files and get the machine back up to working order?
It may be that with their familiarity, they can be more helpful than a forums guesswork done at a distance.

I don't think I understand what you are trying to say.
It's my personal laptop and I'm in a problem. As a human being I feel like doing everything possible to secure my files as long as it's legit and I don't see any wrong in this!

1 Like

He trying to say everybody trying to help you with best options but we don't know what you have tools to backup your files.
With all this dialog i understable you want back all your files.
The solutions what we gived you no lucky.
That why @Aravisian gived to you a solution your laptop manufactured produce or some service who can help you back your all data files or repair problem with your password. Propably you can also find some another websides with that issue or discord channels.
Propably people here have more experience with help you back your password.

@Levi , I am sorry : I confused your posted issue with a different one:

Sorry about the mixup.

1 Like