Can't mount network share as read/write

Hey guys!

I'm having a weird problem and I'm desperate after doing research for almost 4 hours now.

I just purchased a NAS device and it works fine and I've created 2 shared folders (all permissions should be fine on the NAS end as well) and I've been following a guide that says to mount these shares in fstab. Said and done. However, I can NOT change the shares' group, the shares', nor the shares' permissions and it shows as read only (755) and I have no idea WHY!

Here's the entry in fstab for the server (Please disregard the childish name lol)

//kleinegeileslut/8TBSeagateFilme /mnt/8TBSeagateFilme cifs uid=1000,gid=1000,rw,username=Donatus,password=(redacted) 0 0

As I thought, the


should imply read AND write permissions, however, chmod 755/775/777 doesn't do ANYTHING. Trying to change the permissions as a system user with Nautilus makes it switch back from "read and write" to "read only" instantly and I'm freaking desperate.

Could anybody point me to the right direction?

Also, this is what I get when I ls -lhs

drwxr-xr-x 2 donatus donatus 0 Aug 25 23:44 8TBSeagateFilme

So no read permissions for me and I need write permissions on that share, as it is for a Plex Media Server and automation programs like Sonarr.

Any help would be gratefully appreciated :pray:

This is confusing because the above states that the owner (you) has read, write and execute permissions.
You might try:

//kleinegeileslut/8TBSeagateFilme /mnt/8TBSeagateFilme cifs vers=1.0,uid=1000,gid=1000,rwx,username=Donatus,password=(redacted) 0 0

Thank you once again. I did that, still no dice. It seems like there's no way to give execute and write permission to that NAS share :cry: Weird thing is (you remember: I'm a noob) when I earlier opened folders as a system user with Nautilus, I was easily able to grant permissions to that folder by just changing the settings. When I now try to change the settings, it wouldn't get applied, instead switching back to "read only" instantly. I'm despereate :confused:

Thank you for your help, sigh

Did you install cifs-utils?

And create the mount point:

sudo mkdir /media/NAS/.......

Hey there! Yes I've created the mount point and no :thinking: I didn't install cifs-utils. How would I go on installing them?

sudo apt-get install cifs-utils

Also, try using
/media/NAS/8TBSeagateFilme (you will need to make the / pt sudo mkdir)
Instead of:

Thank you sir :slight_smile: Seems like I had cifs utilities installed already, but that's an interesting point!

Could you maybe craft me the path from my bits? I'm too tired to get the variables tonight :smiley:

What should be the /media part and what the /NAS part?

EDIT: Don't get me wrong btw! I can access the shares from within the file manager on my (Zorin) computer. Just not by other programs that desperately need write privileges :confused: So I figured it must have had something to do that it's not properly mounted. Btw the name of the entire NAS is "kleinegeileslut" :smiley: Or let's say it's the servers' name

sudo mkdir /media/backups

Replace nnn.nnn... with the actual I.P. address

//nnn.nnn.n.nnn/kleinegeileslut /media/kleinegeileslut cifs vers=1.0,uid=1000,gid=1000,rw,username=Donatus,password=(redacted) 0 0

I wonder if it would work better without the user/pass and rely on your Home Directory access for the security... It may, but you must decide the essential parts of your security.

Is this correct?

//myIP/kleinegeileslut /media/kleinegeileslut cifs uid=1000,gid=1000,rw,username=Donatus,password=(redacted) 0 0

It prints an error:

Bildschirmfoto von 2021-08-26 01-02-35

Thank you for the previous redaction btw :pray: Too quick

Also: That other, less secure way sounds interesting. How would I go about that?

I messed up... sorry...

sudo mkdir /media/kleinegeileslut

//nnn.nnn.n.nnn/kleinegeileslut/media/kleinegeileslut cifs vers=1.0,uid=1000,gid=1000,rw,username=Donatus,password=(redacted) 0 0

No issue man! :heart:

That's what I've already done, but it gives the above error anyways.

There's the mount point missing, isn't it? What I did was

// /media/kleinegeileslut cifs uid=1000,gid=1000,rw,username=Donatus,password=(redacted) 0 0

and it still prints this error:

You can find that here:

1 Like

Thank you man! I will try that prior to keep fumbling with fstab, as I don't see any way out of my misery at the moment :smiley: I'll let you know soon how it went :slight_smile:

1 Like

I can't be awake long enough to be up all night to get lucky :joy: Fml.

This nfs method is now giving me this error:

And this is my fstab entry: /media/NAS/8TBSeagateFilme nfs defaults 0 0

I also ran

sudo apt install nfs-common

prior to this. Any thoughts again?

Hey therrre! I did it!!!! It's working! I can't believe it :joy: The catch was that - for the NFS share - the mounting path cannot be /share1, but /volume1/share1. After that I was able to mount it through fstab and all worked well. I was able to grant write permissions as easy as an angel in the dark, so all good now on this end :heart:

1 Like

Hahaha, I see what you did there @Aravisian :joy:

It was me changing to something more pleasant.


My apologies. I'll watch my language from now on :slightly_smiling_face: