Can't move items or make groups in gnome layout app grid

Under gnome 3, you can customize the names and contents of folders/groups in the full-screen application grid by clicking on the edit button or dragging-and-dropping. You can also create new groups by dragging-and-dropping one application icon onto another.

Under Zorin all these things are impossible. You cannot change the contents or name of the “Utilities” group (the only group present) in the full-screen app grid. All dragging-and-dropping of apps into or out of a group is disallowed and there is no edit button next to the name.

How can I restore this functionality, and why was it disabled?

Also the extension “Appfolders-management” doesn’t work.

I found a way to put applications into appfolders through software center, but it still doesn’t allow me to remove them from “Utilities”. Wow Zorin really is making basic customization hard…

Hi @gurk, welcome to the forum!

The ability to customize the icon layout and folders from within the full-screen app grid was added in Gnome Shell 3.34. As Zorin OS 15 is based on Ubuntu 18.04, it uses a slightly earlier version of Gnome Shell to ensure stability. As a result, you will need to use the Software store to do this in the meantime.

You can remove system apps from the “Utilities” folder by following these steps:

  1. Open the Software store > Installed
  2. Scroll down to the “System Application” section
  3. Click on the (select) button in the top-right corner of the Software store window
  4. Select the apps you wish to remove from the “Utilities” folder
  5. Press the “Remove from Folder” button at the bottom of the window

The ability to customize the icon layout and folders from within the app grid will be added in the next major version of Zorin OS, which will ship with the latest version of Gnome Shell.


Thank you @AZorin. My apologies for assuming the feature was removed instead of not yet available.

I found those steps elsewhere already and followed them, but that only removed some of the apps from the Utilities AppFolder. The remaining ones are Archive Manager, Backups, Characters, Disk Usage, Disks, Fonts, Logs and Screenshot. If I try to select those again, “Remove from folder” is greyed out. They’re still in Utilities.

If some apps can’t be removed from the Utilities folder directly using the Software store, please try following these steps:

  1. Open the Zorin menu > Software
  2. Search for & install “Dconf Editor”
  3. After the installation, open the Zorin menu > System Tools > dconf Editor
  4. In the dconf Editor app, navigate to /org/gnome/desktop/app-folders/folders/Utilities/apps
  5. Make sure that the “Use default value” option has been switched off
  6. Remove the desired apps from the list and click the “Apply” button

The following apps are listed with these code names:
‘org.gnome.FileRoller.desktop’ = Archive Manager
‘deja-dup-preferences.desktop’ = Backups
‘org.gnome.Characters.desktop’ = Characters
‘org.gnome.baobab.desktop’ = Disk Usage Analyzer
‘org.gnome.DiskUtility.desktop’ = Disks
‘org.gnome.font-viewer.desktop’ = Fonts
‘org.gnome.Logs.desktop’ = Logs
‘org.gnome.Screenshot.desktop’ = Screenshot


Thank you! That partially worked.

OK, so now there’s 19 applications left over that I still can’t put into appfolders. How do I find their names to add manually to dconf?

For example, “org.gnome.FileRoller.desktop”… Where would I find the equivalent name for a snap application to put in dconf?

Actually, I just tried adding “org.gnome.FileRoller.desktop” to an appfolder in dconf and it didn’t work either.

Someone a while back on the old forum was asking when would Zorin Grid be ready and forgot about the project Team Zorin are working on (Silly me) and suggested this as the [wrong in that instance] answer - I don’t know how ‘tweakable’ it is:

“Zorin App Grid - Show the App Grid button in the panel.” So, not related to grouping shortcuts. Thanks though.

Any way to upgrade Gnome to a later version that fixes these problems?