Can't move mouse

I Cant move my mouse as soon I log in but
On the Log in screen its all fine. Some one have an Idee ?. Thanks for every help :slight_smile:

Is this a touchpad, USB Mouse, Bluetooth mouse and so on?

Hello, its a Touchpad I even tried a ps4 controller whit its touchpad but it also did not worked

Well, PS4 is a specialized controller and would need drivers installed.
Some things you can try:
First, launch settings from the App menu > Mouse and Touchpad > Touchpad and ensure it is set to Enabled.
You may have an option in those settings to "ignore touchpad while typing", so please check if that is enabled, too.

More in depth things to try:

sudo apt install --reinstall xserver-xorg-input-synaptics

Reboot and test.

If no good, try checking your BIOS settings if you have Graphics options and see if you are set to discrete or to hybrid graphics. If you have the option, try Hybrid graphics.

Lastly, you can try the following:
Boot to desktop, then hit ctrl+alt+t and in the open terminal run

sudo rmmod psmouse


sudo modprobe psmouse proto=imps

If that gets the mouse working, you can make the change permanent:

sudo nano /etc/modprobe.d/options

Add the line options psmouse proto=imps - save the file by tapping ctrl+x, then y then enter. Reboot and test.


Until the mouse works, you can get around using super and the arrow keys as well as tab and shift + tab to move around the desktop. alt + tab to switch between applications. alt + F4 to close applications.

Ok, found the solution :slight_smile: my touchpad was somehow set to off. I dont know why but hey, thanks for your help :smiley:

You could have always reverted to this!:

Computer Delete GIF

Sorry I meant:

Tom And Jerry Cartoons GIF by HBO Max

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.