Can't play video or music on lite 15.3

Hello, I just installed Zorin Lite 15.3 on mom's old Inspiron mini trying to get it working again, at least for office stuf.
Everything works ok considering the hardware but when i try to reproduce any kind of audio or video it does'nt (on youtube video stays on place but does not move, if I move the bar to some random time of the video it stutters a fraction of audio repitedly, on bandcamp it also dont move but not even the stutter comes out).
I thought it could be lack of codecs in the os but testing in a virtualmachine from another pc it works just fine.
Also tryed puppy os on the Inspiron mini and media plays normaly, althought I think Zorin would be a much better option for moms.
If anyone have any tips.
I'm not by far an expert on linux but I can follow instructions and read articles if necessary.
Thanks in advance! :grin:

Hello and welcome to the forum :slight_smile:

My HP mini Netbook does the same thing if I move the slider while playing video.
I think it is a limitation of the hardware.

It is because Puppy loads OS on the RAM which can overcome much of the hardware restriction.

This I cannot disagree :wink:

1 Like

What browser are you using?
This sounds like a hardware - Hardware Protected Video Decode issue.

1 Like

Thanks for the replies!
I'm currently using firefox but not even a downloaded mp3 can be reproduced nor with parole or vlc.
Searching for the hardware decoder I found the following codes

sudo apt-get install xserver-xorg-video-intel

but I already had them

sudo apt-get install --install-recommends xserver-xorg-hwe-18.04

also not resolving anything

apt install xserver-xorg xserver-xorg-video-all

this one at least wich unfortunately didn't solve it.

found them in these threads

Is there any way to get around those limitations?

What is the output of:

inxi -G

1 Like

Graphics: Card: Intel US15W/US15X SCH [Poulsbo] Graphics Controller
Display Server: x11 (X.Org 1.19.6 )
drivers: (unloaded: fbdev,vesa) FAILED: modesetting
Resolution: 1024x600@60.31hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0, 128 bits)
version: 3.3 Mesa 20.0.8

From the app menu, can you pull up Window Manager Tweaks and open it. Go to the Compositor tab
Click the checkbox for Enable display compositing to turn it off.

Log out, and back in and test...

1 Like

Still fails :c

In terminal can you run

sudo nano /etc/default/grub

What does the following line say on yours?

1 Like

quiet splash

Ok, what is the output of

grep modesetting /var/log/Xorg.0.log

1 Like

[ 65.410] (==) Matched modesetting as autoconfigured driver 4
[ 65.414] (II) LoadModule: "modesetting"
[ 65.415] (II) Loading /usr/lib/xorg/modules/drivers/
[ 65.415] (II) Module modesetting: vendor="X.Org Foundation"
[ 65.602] (==) Matched modesetting as autoconfigured driver 4
[ 65.605] (II) LoadModule: "modesetting"
[ 65.605] (II) Loading /usr/lib/xorg/modules/drivers/
[ 65.605] (II) Module modesetting: vendor="X.Org Foundation"
[ 65.605] (II) UnloadModule: "modesetting"
[ 65.605] (II) Unloading modesetting
[ 65.605] (II) Failed to load module "modesetting" (already loaded, 0)
[ 65.607] (II) modesetting: Driver for Modesetting Kernel Drivers: kms

And this machine only has the onboard intel dedicated graphics?

1 Like

I think so

Video type integrated on system board
Video controller Intel GMA 3150
Video memory 8 MB system memory (shared)
LCD interface LVDS
Video decoder (optional) Crystal HD Media Accelerator
Frame rate Upto 30 fps
Resolution Upto 1080p or 1920x1088
Formats Codec Support
MPEG-4, DIvX(MPEG-4), AVC(H.264), VC-1(WMV-9)

Inspiron Mini 1012 Comprehensive Specifications (


Can you

sudo nano /etc/default/grub

Change the line we looked at earlier to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"


sudo update-grub

sudo update-initramfs

sudo apt update && sudo full-upgrade

sudo reboot

and test...

1 Like

sudo update-initramfs
You must specify at least one of -c, -u, or -d.

Usage: /usr/sbin/update-initramfs [OPTION]...

-k version Specify kernel version or 'all'
-c Create a new initramfs
-u Update an existing initramfs
-d Remove an existing initramfs
-t Take over a custom initramfs with this one
-b directory Set alternate boot directory
-v Be verbose
-h This message

1 Like

sorry (sheepish)

sudo update-initramfs -u

1 Like

I just wondered if you noticed this part.
Do you think Puppy has more codex than Zorin?

Yes, that was why I tried disabling the XFCE compositor... Not aware of Puppy having more codecs. If anything... It would have less, I would think.

I thought Puppy uses XFCE desktop.