Can't play videos in Cawbird 15 on Zorin 16 Pro OS

According to Cawbird support this is an issue with the version of gstreamer included in the distro I'm using (Can't play videos - Cawbird 15 on Zorin 16 Based off Ubuntu 20.04 LTS · Issue #448 · IBBoard/cawbird · GitHub). I know Zorin OS 16 is based off an older ubuntu 20.04 LTS version. So what commands do I run to preform an update or re-install of GStreamer and all it's packages / dependencies?

I have an idea of the commands off another forum, I just don't want to make a mistake removing gstreamer core...so if you could confirm the commands that would be great.

I don't touch social media apps, period. Do you have any of the Qt5 gstreamer packages installed?

1 Like

From what cawbird github support stated the version of gstreamer included in Zorin 16 Pro OS is grossly outdated. Is it possible for devs to push an update to gstreamer on the "software updates" for zorin? Or at least provide some commands or a guide to update it? I suspect updating gstreamer will solve the problem. I did purchase pro if that in any way can be utilized to get additional support on this i'de like to do that as I do use twitter quite a bit and it slows down things a ton.

Zorin OS comes with gstreamer 1.16.2
I would hardly call that "Grossly" outdated. There have been two additional releases.
What does the following yield?:

sudo apt install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-bad1.0-dev gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio gst-plugin-gtk

1 Like