Can't print (HP printer) -Zorin 16

I connect my printer to my computer and Zorin recognizes it. But when I click print any doc, the printer's state is set an undefined time to 'processing'. Then a banner is shown with an error message: error connecting to device.

Screenshot (error message at bottom-right corner) :

Hello and welcome to the forum.
Did you try removing printer then add it again?

Sometimes printer auto detection could guess it wrong.

Yes, I've tried it and it didn't work :c

Funny thing was that I had a printer problem myself while I was trying to help you.

I shutdown and restart my WiFi connected Brother printer and all is well now. You might want to try this age old trikc.

I did it and nothing happened. Could it be a driver issue?

How is your printer connected?
WiFi, LAN or USB.

USB connection

You can download HP printer driver here:
https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

Thank you! What distro should I choose when it asks? Ubuntu? Because hplip doesn't support Zorin

Yes, Ubuntu.
Zorin is based on Ubuntu.

Installation instruction:
https://developers.hp.com/hp-linux-imaging-and-printing/install/install/index

You need to do it in terminal.

I tried it but I got a lot of problems installing the missing dependencies. However, I ran hp-setup -i and gave me the same error with more info that could be helpful.

You can also try using CUPS to setup printer.
sudo apt install cups

sudo systemctl start cups

sudo systemctl enable cups

After that you can access to your CUPS server via any Browser of your choice at the following address:
http://localhost:631/

Follow instruction there to setup printer.

I set up the printer successfully using CUPS but again, the same error

I am at my wits end...
Could you verify the USB cable connection?
Integrity of cable that is.

Can you please run the following in terminal:

sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds
libsane-hpaio printer-driver-hpcups printer-driver-hpijs
sudo rm -rf /usr/share/hplip/

Sometimes, more than one copy of hplip can confuse the whole thing, so they must all be removed.

sudo apt-get autoremove

Use wget to get the driver:

wget https://download.sourceforge.net/project/hplip/hplip/3.21.6/hplip-3.21.6.run

sh hplip-3.21.6.run

Then please follow the prompts and the Printer Wizard ... and let's all cross our fingers and toes.

1 Like

FrechPress, I've tried on every port but nothing. And Aravisian, thanks for help but it didn't work. Buuuut, I think there is light of hope here Cannot connect to printer over network from Linux - HP Support Community - 4803530 . I don't understand what FoxP said but maybe you could help me

Can you try:

systemctl restart snmpd.service

sudo apt purge ippusbxd

sudo hp-check

It didn't work :C

This is the most common thing ever said to me on this forum...

I am going to have this chiselled onto my tombstone.

R.I.P.
Aravisian
"it didn't work..."
01/01/1901 - 01/01/2021