Can't scroll with touchpad!

Have you considered installing Zorin 16?
I have been using Zorin 16 and Touche works like a charm to configure my multitouch trackpad.

I didn't go for 16 because it's still in beta

Tried a few, none worked for me...So made one for myself.

Screenshot from 2021-08-08 00-12-28

It seems my touchpad is not recognized at all.

I have been using 16 for several modefinitelynths without any issue. This definitely the most stable beta OS I've ever used.

But you can also try out version 16 in Live session without installing to see whether newer kernel/drivers make any difference for your hardware. In my case, it was a big improvement for my trackpad.

If I install beta, can I go to final release from it directly or will I have to download entire iso again?

I think you would better test Live session before making any decision. I am determined to do a clean install myself since I will purchase the Ultimate edition when it is out.

Very well, I shall give 16 a try. Hope that'll work.