Can't scroll with touchpad!

Hi! I just installed Zorin 15 core in my Dell Vostro 14 3400 Laptop (Intel Core i3-1115G4). Problem is, I can't scroll using touchpad with 2 finger gesture. And there isn't any such option in device setting whatsoever! Also having problem with double tap (needs 3 taps to open anything), can't bring up context menu with 2 finger tap. Please help.

I'm using Zorin Lite, but I'm sure you'd have the same options available in Zorin Core. To adjust your touch pad settings, choose the "Settings" option in your applications menu (the "Z" on your desktop) and find the Mouse/Touchpad option in the menu.

When you double-click on it, you should see a window similar to what I have in the attached screenshot. Click on the Touchpad option and then choose your desired options (tap to click, edge scrolling or two finger scrolling). I'm guessing that you're finding that you have to click three times is because of the sensitivity setting is set too low. You can adjust that from this menu, as well.

1 Like

Gnome is actually pretty different. You must install gnome-tweaks tool just to access many settings.

sudo apt install gnome-tweaks

I think Frenchpress is also the resident expert on gesture and touchpad.
Perhaps she can help.

That's some great arrow work on your screenshot. I think you could teach me a thing or two.

1 Like

I wasn't aware of that. Thanks for letting me know. It's also unfortunate that Gnome hasn't kept a simpler approach. I guess that's one reason why I don't use a Gnome desktop anymore.

Just an FYI, I use Fotoxx as my photo editor. It makes it real easy to add arrows and such to images.

This is my Mouse and touchpad settings!

Trying

Screenshot from 2021-08-07 11-56-33

After this?

I really don't know if this will be of any help... but I found this:

You can open Gnome-tweaks from the app menu. Open the app menu and start typing tweaks and the autosearch will put tweaks first on the list in the menu.
Open Tweaks and navigate to Keyboard and Mouse.
At this point, you will need to explore the settings and see if anything there helps you. I do not use the Gnome Desktop, so I lack experience with its settings sometimes.

If the above is not helpful, you may need to adjust some gsettings - or install a Supportive Gnome-Extension such as:
https://extensions.gnome.org/extension/1253/extended-gestures/

Gnome does not support many things out of the box and a user must install Many indie Gnome-Extensions just to get it working.

1 Like

Oh my...Linux is...complex. Turns out my system can't detect my sound card, I tried
sudo apt-get update
sudo apt-get upgrade

This worked on mint but not here...

Could you please start a new thread on the topic of Sound Card not detected on Zorin 15 Core? That way, the topics will not get confusing.

Have you had any luck on the gestures and Touchpad?

No unfortunately. Gnome tweak had the options, but enabling them does no good. I've even rebooted. (I'll post new topic about sound after this touchpad issue)

1 Like

Can you try switching from libinput to synaptics:

sudo apt install xserver-xorg-input-all xserver-xorg-input-synaptics

sudo reboot

and test

Screenshot from 2021-08-07 12-34-15

Uh what is this?

By the way, does dual booting have anything to do with this?

It looks like you are using HWE (Hardware Enabled). Try instead:

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

This did and then?

Looks like it installed. Can you reboot and test?

Still same unfortunately.

Can you check against solutions in other threads?

Perhaps Zorin forum member @FrenchPress can be of more help.