Touchpad scroll in Zorin 16 Pro

Hi. I purchased Zorin for the love that I can ditch Windows for something that is more newbie friendly. However I am not able to scroll with my touchpad. I use an HP Elitebook. Have already tried shifting to synaptics form the terminal as was mentioned in this link: Can't scroll with touchpad!


What is the terminal output of

uname -a

If higher than 5.11.0-36, can you run in terminal:

sudo apt update && sudo apt full-upgrade

Then reboot and test and relay the results here?

Tried the full-upgrade and reboot. Still not working.

Can you please try the module prober

sudo modprobe -r psmouse

sudo modprobe psmouse

Then test?

Nope. Still the same. Do they have touchpad scroll in Lite? I saw your post praising it over core :slight_smile:

I have no idea...:wink: I have never used an HP Elitebook...
You can test it out using the LiveUSB.

Thanks, will definitely give it a try. :slight_smile:
In the meanwhile, any other solution that you suggest for this problem? Not having touchpad scrolls drains my productivity bigtime.

Do you use two-finger scrolling?
In Settings > Mouse & Touchpad > Do you have settings for scrolling that are currently disabled?

I only see mouse-related settings in the settings area. Also, based on the terminal screenshot, is my touchpad not detected? I also tried running Synaptics (syncient) through terminal but that too gives the error that couldn't find synaptic properties.

1 Like

What is the output of

cat /proc/bus/input/devices

No trackpad in the list.

What year model is your Elitebook?

2015 I guess.

There are two possibilities that come to mind:
Libinput or the Linux kernel.
Since you had tried installing Xorg-Synaptics trying to troublehoot the issue, it seems unlikely to be Libinput.
You might try either an earlier kernel or a later kernel... Given that at this point, you should be using the 5.13 kernel on Zorin OS through the updates, and it being a 2015 model, I would not assume that a later kernel would help.

Try the 5.8 LTS kernel:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot and use Advanced Options for Zorin to boot from the 5.8 kernel. Once you reach the desktop, double check with

uname -r

It should be 5.8.0-63
Then test your touchpad scroll.

I am so sorry that I have been bugging you again and again but it is still not working. Nor is the trackpad still detected.

Btw, I just realized, I was using 5.11 before. Will updating to 5.13 be any good solution?

sudo apt update && sudo apt upgrade

should take care of that. Zorin OS is now using the 5.13 kernel. You may have just not run your updates, yet.

I wonder if your Elitebook is using Elantech...

It still shows 5.11.0-46 even after running the query in the terminal :slight_smile:

In terminal, pelase run

dpkg --list | grep linux-image

And relay that output here.