Can't stop Zorin loading

I run Zorin on an old MacBook and it works but way too sluggish so I was trying out lighter distros but after loading about 4 satisfactorily, now I can't stop Zorin loading no matter what distro I try and load. I was thinking of using Darik's Boot and Nuke if it would load, but I am afraid it might make things worse for me. Any ideas? I can use the Zorin (base) if that helps.

I am not an expert in this field but I suggest using another hardware (not Apple related) for Linux.

Can you please go further into detail? I do not understand what you are describing here.
Have you installed four other distros? Or is this during trying distros with LiveUSB?
Please clarify what steps you have actually performed such as whether something is installed as bare metal install. Were they installed on Different Drives?

If a user installs Zorin OS, for example, then later installes Linux Mint alongside of it, then the newer Grub Install on Mint will take over making Mint the default OS to load grub first. If they then install POP_OS, then the newer Grub Install on POP_OS will be become first in line and so on.

I’ll try and explain better !

I wanted to revive my old MacBook, I put one distro after the other on USB flash drives and tried them, not side to side, and found Mint worked but keyboard did not, Kubuntu was OK and Zorin was best so I installed it alone onto the Mac’s drive but found it struggled. So I decided to settle on Kubuntu but it didn’t load and neither did any of the others.Your explanation of each one’s grub taking over sounds right, but that would mean Zorin’s grub won’t let go now, whereas it did let go when I originally was going through the live usb distros. When I try to boot from the usb I can tell it is trying to load for a few seconds and then defaults back to Zorin. Is there any way to change the grub from within Zorin, or from a usb stick? I wonder why it decided to become dominant in the first place?

Thanks for your help.

The Grub Zorin OS uses is the same exact Grub used by POP, Mint and Ubuntu. There is nothing in it that can hook into the computer and not let go.
The cause must be something else, since there are no hooks.
(Don't get me wrong, I can see what you are thinking and why you would consider that on its appearance).
What happened there is known as the X - Y problem in computing.
The X - Y problem is when a user asks about solving the assumed problem, instead of describing their symptoms to define the problem to be solved.

What this sounds like is that the USB stick is failing to boot.
This can happen after a certain number of read/write cycles. I recommend completely wiping and formatting the USB stick from fresh or trying a different USB stick. Then burn your .iso to boot or use Ventoy to test other distros.