Caps lock number keyboard always off in login screen

Hi! I use a password with all numbers, and in every startup the "caps lock" for the number keyboard is always off, how can i enable from start this feature?

Hello and welcome to the forum.

Check your EFI/BIOS.
There should be a settings for numeric keys ON/OFF at the start up.

Hi! I have a Dell Optiplex and i cant find this options in the BIOS :frowning:

Which model?
Do you have the latest version of BIOS?

dario-OptiPlex-9010

Looks like the latest BIOS is O9010A30.
https://www.dell.com/support/home/en-us/product-support/product/optiplex-9010/drivers

Also, If using Zorin Lite (XFCE):

sudo apt install numlockx

sudo nano /etc/lightdm/lightdm.conf

Add this line: greeter-setup-script=/usr/bin/numlockx on and save and exit.

Install numlockx on Zorin Core (Gnome):

sudo apt install numlockx

Navigate to ~.profle and add these lines to it:

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

Save and exit, log out and in to test. (Or reboot).

1 Like

I try this but it does not work for me :frowning:

Sorry, I do not use Gnome D.E. so, I am no expert.
try:

su gdm -s /bin/bash

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

Hi! No problem, im not an expert nethier. Your last message also dont work, it not found "gdm" command.

Try just the gsettings option - What I am using may be too outdated for gnome 3.38...

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on