Challenge installing boot loader

I recently decided to dual boot Linux alongside Windows 11.
I have now (I think?) installed Zorin OS Pro, but am unable to boot into it.

Steps I have taken:

  • Partition my SSD (50 GB for Zorin)
  • Created a bootable USB from balenaEtcher
  • Inserted the USB, and without doing anything else, it booted to the USB
  • Installed Zorin OS on the new partition - I chose the "Something else" option. I was prompted to reboot
  • When rebooting it just goes to windows. I figured that GRUB was not installed properly. I therefore want to boot from the USB to install GRUB
  • I have tried to change the boot order in UEFI so that USB is on top and "Ubuntu" is on top.
  • When booting to "Ubuntu", I just got stuck on the Microsoft logo (I have a Microsoft Surface Laptop 3)
  • When booting to USB, I was just sent back to UEFI.
  • I flashed the USB again, this time with Rufus. When doing this I get stuck at "launching efi boot bootx64.efi"
  • I tried flashing the USB again with Rufus, this time choosing DD instead of ISO. This just boots me into UEFI again.

So yeah, I am not sure what to do. As far as I can tell, Zorin is installed, since "Ubuntu" shows up in the boot order list.
But for the life of me, I cannot boot from the USB, to install GRUB...

Welcome to the Forum!

When You have chosen that Option: How did You set up the Partitions? I mean how did You create them. And what did You have chosen for the Boot Loader? Did You have chosen the Windows Boot Manager:

I had one big partition where I freed up some space in Windows using AOMEI. During the installation I made a new partition with the new space.
Here are the settings I chose:

  • Type: Primary.
  • Location: Beginning of this space.
  • Use as: Ext4 journaling file system.
  • Mount point: /.

And then /dev/nvme0n1 (the main disk where Windows Boot Manager is located) - I think this is where Windows Boot manager was at least. I took a screenshot of my setup before I made the partition (and I did not change the boot loader installation)

1 Like

Yes, that looks right.

And that could be the Problem. Yes, the Windows Boot Loader ist on /dev/nvme0n1. But this is Your whole NVME Drive anmd not the specific Partition where the Boot Loader sits. You can see on Your Picture that there ist the Windows Boot Loader listed as /dev/nvme0n1p1:

And this is an EFI Partition. And an EFI Partition is needed for the Boot Loader.

And under the Partition Table You have the Option ''Device for boot loader installation''. And there You should choose the Option what I marked on my Picture. So it lands directly there.

1 Like

Okay, Thank you so much! So what do I do now?

It may be possible to manually install the bootloader but I'm not certain what the correct process for that would be.

I recommend you try installing Zorin again, using "something else" as before but this time pick the EFI System Partition for the bootloader instead of the whole drive as @Ponce-De-Leon identified.

1 Like

I would think the easiest Way would be to install Zorin new. How to repair the Bootloader in your Situation unfortunately I don't know. Maybe a more experienced User can give You Advice for that.

When You should decide to install it new: When the Zorin Installer runs, You should have an Option to install Zorin alongside Windows. Maybe You should use this Option. Then the Installer makes the Partitioning automatically. You get then a Toggle to define how much Space You want to use and the Rest makes the Installer. I can only speak for myself, but this works for me erverytime.

But if You should prefer to do it with the ''Something else'' Option it is totally okay.

You didn't needed to do this.
In the Zorin OS installer, just press "install alongside Windows Boot Manager", and it will ask you the space for Zorin and Windows (and you would have selected 50 for Zorin)

And when you do this it does all the other stuff automatically (including grub installation).

So you can try to delete the 50G partition you created, put the windows partition back to its original space, and run the installation process again, but selecting "install alongside Windows Boot Manger" this time.

Thats what i'm talking about, just seen this message.

Thank you everyone. I managed to solve it by using EasyUEFI. With that I was able to create a new boot point, and I was able to boot into and use Zorin OS without a problem.

Thank you so much!

2 Likes