Changing default sound output on boot

When I open my pc, My pc's sound not worked. So, I went to setting>sound>output and changed output device option analog to line out. Then my pc's sound worked. Every time I had to change my sound setting. I'm using core Zorin OS 16 and there has no dual boot. This is my daily driver.


Try sound - How do you set a default audio output device in Ubuntu? - Ask Ubuntu

1 Like

Thank you so much. It work it !. Zorin os Helping support is awesome. I love it. :heart_eyes:

2 Likes

Thanks for the update- because this has been a common complaint / request. I have bookmarked this thread for the future when a user runs into this.

2 Likes

First go to setting>sound>output and output device. You have to choose the option which will bring up the sound in the sound box or headphone.
In my case, I'm choosing Line Out - Built-in Audio.

And open the terminal and write this command

pactl list short sinks

Copy the name of the output device that will be the idle output device. In my case, that is first item [alsa_output.pci-0000_00_1b.0.analog-stereo]

Now open Startup Application and click Add.

Screenshot from 2022-01-03 10-25-08
On the command input write this text

pactl set-default-sink [paste your output device name]

In my case, I'm writting this command

pactl set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo

Screenshot from 2022-01-03 09-41-25

Write name as your wish and click Add.
Screenshot from 2022-01-03 09-42-48

1 Like

Thanks for writing the detailed walkthrough. This will be very useful for future readers.

Since Aravisian noted the value of this thread, I took the liberty to change the title for easier searching - I hope you don’t mind.

If there is a wish to revert to the original title, please note it is: “Every time when I opened my pc, I need to change sound output setting manually for sound listen from sound box“

1 Like

It's okey no problem, I'm glad you solved my problem so sincerely. Again thank you :two_hearts:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.