Changing Pro time source to time.nist.gov

Becauuuuuuse I can't leave anything alone for more than a few minutes, I decided to change the time server to the time.nist.gov in the U.S. Not having a clue what I was doing I did a world wide search on Ubuntu. In the /etc/systemd/timesyncd.conf file I removed the comment mark and made this change...

NTP=time.nist.gov

It looks like it worked to me...is that the case? Below are my actions, not shown is the edit action of the .conf file.

In the output I see where the vendor preset is enabled. Did my setting over ride this, or is this something else?

If this is correct and will help someone else, the mods can move the thread to the Tutorials section if they want.

thanks

lou@lou-zorin:~$ sudo -i
root@lou-zorin:~# man chmod
root@lou-zorin:~# man chown
root@lou-zorin:~# chown lou /etc/systemd/timesyncd.conf

#edited file at this time and saved, then returned ownership to root

root@lou-zorin:~# chown root /etc/systemd/timesyncd.conf
root@lou-zorin:~# sudo systemctl restart systemd-timesyncd

# looking to see what I may have broken

root@lou-zorin:~# systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2022-10-19 18:45:53 EDT; 1min 32s ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 6414 (systemd-timesyn)
Status: "Initial synchronization to time server 132.163.96.4:123 (time.nist.gov)."
Tasks: 2 (limit: 18772)
Memory: 1.3M
CGroup: /system.slice/systemd-timesyncd.service
└─6414 /lib/systemd/systemd-timesyncd

Oct 19 18:45:53 lou-zorin systemd[1]: Stopping Network Time Synchronization...
Oct 19 18:45:53 lou-zorin systemd[1]: systemd-timesyncd.service: Succeeded.
Oct 19 18:45:53 lou-zorin systemd[1]: Stopped Network Time Synchronization.
Oct 19 18:45:53 lou-zorin systemd[1]: Starting Network Time Synchronization...
Oct 19 18:45:53 lou-zorin systemd[1]: Started Network Time Synchronization.
Oct 19 18:45:53 lou-zorin systemd-timesyncd[6414]: Initial synchronization to time server 132.163.96.4:123 (time.nist.gov).
root@lou-zorin:~#

Does running

timedatectl

Show NTP service: active?

Yes...if I understand the output correctly.

lou@lou-zorin:~$ timedatectl
Local time: Wed 2022-10-19 19:13:26 EDT
Universal time: Wed 2022-10-19 23:13:26 UTC
RTC time: Wed 2022-10-19 23:13:26
Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no
lou@lou-zorin:~$

Well, everything looks good and unbroken, then.

OMG!! I actually did something in Terminal and did not break my install. :laughing:

Don't worry... you'll get used to doing that. :wink:

2 Likes

Thanks Aravisian...I appreciate you taking a look at this. :+1: :grinning:

2 Likes