Chown and chmod suddenly seem to be over-ridden

I seem to have suddenly lost my mind. I am trying to change the ownership of python files to root and for all users to have read permission. When I use terminal (sudo chown -v root:root *) from within the containing folder, the output says that they have all been changed, but they have not. ls -l still shows jim:jim. The same with chmod -v a+r *. The output says changed, but they are not. If I use sudo nautilus, the ownership changes to root, but then changes right back to jim. The same with read permissions. They show changed for a split second, then change back. It isn't like I haven't done this a zillion times with no problem. Please help me to step back out of the twilight zone.

This is a strange one.
Do other sudo commands work in terminal? Installing applications?

They do seem to work ok. sudo apt update worked. cd works. ls works. I rebooted just in case, but it did not help.

I cannot believe that it is related, but something else completely unexpected (and upsetting) happened at the same time. Firefox presented me with an offer to try some new color schemes. I clicked 'keep using my old one' and suddenly my home page was changed to It took me 20 minutes to find my local, custom made home page to set it back.

I'm stumped, Jim. The only thing I can think to do for Safety and Security is to reset all permission for Home and For Root. This may mean you would have to go in and change permissions you had previously set and had working before this... Though be cautious of not repeating the same problem.

dconf reset -f /org/gnome/

I will do this reset if I cannot figure out what is going on. I'm afraid that if I do the reset and then cannot change the owners and permissions because of the same problem, my python apps will no longer work ... and I need them. Thanks for your help.

1 Like

I understand 100%...

You could make a whole disk image backup with Rescuzilla before taking a plunge.

1 Like

Thanks for this. I am tempted to use Rescuzilla, of which I was unaware. I just reset my system to Nov 3rd using Timeshift, but it made no difference. I also have a current full backup of /home. I do not have a backup of /root. I wish I did. I'm a little nervous because Rescuzilla isn't obtained from a regular repository.

Rescuezilla is basically a GUI front end of the well-known backup application, Clonezilla.
I have been using Clonezilla for over 10 years, but recommend Rescuezilla for my family members who are less nerdy than myself :sunglasses:

I have tried to image the internal NVMe drive using Rescuezilla, but I have failed. I have two external USB 2T drives connected. The backup failed to the first external drive twice. I cannot get most of the utilities to launch in Rescuezilla so I was unable to save the stack trace. The final line says ErrNo 5 - I/O error. Each time the following files were copied to the USB drive before the error happened:
After two tries with USB drive 1, I switched to USB 2T drive 2, but exactly the same thing happened. The above files were copied, then an ErrNo 5 occurred. Both drives had 2 terabytes available. I tried and failed to launch all of the included apps except for filemanager, imageviewer and devicelist which did launch. I got rescuezilla from the rescuezilla website. On the chance that the error was on the internal NVMe storage device, I examined the SMART data using the nvme utility. No errors were reported. Can you suggest something more that I can try in order to get this drive imaging to work?

OK. I have discovered that I can use both chown and chmod if I first copy the folder containing the Python files to /usr/bin. There the file attributes change. I do not understand why these to commands do not work on files in:
/home/jim/DocumentsE/Develop/Jim/aa_python/password/v2.0.0 Live. (Note that DocumentsE is on a TrueCrypt mounted filesystem.)

I have partially resolved the chown/chmod conundrum, but I still want to be able to use Rescuezilla. Any ideas?

I'm not certain how to move the Rescuezilla question to its own thread so I created a new topic for it. However, it is still hanging here. I do not want to close this topic because the chown/chmod question is not resolved.

1 Like

I finally got the image of the system device created. Then, I executed the dconf reset -f /org/gnome/ command. Wow. I have my work cut out to get my system back to the way it was unless I restore the image. Anyway, it did not resolve the chmod/chown issue.


Ok. I have determined that this 'problem' only occurs on my TrueCrypt mounted file system. chown and chmod claim they made the requested changes, but have not. A quick google and many, many references to this 'issue' were found. One such post said that the solution was to use the following TrueCrypt options when mounting the file system: uid=1000,gid=1000,umask=0002
This did not work for me, but I don't care. Now that I understand that this only happens on my truecrypt volume, I can work around it on those rare occasions when I need to change owners or permissions.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.