Chrome and Edge no longer listed in the Software app

I have noticed a seeming issue with updates to Google Chrome and Microsoft Edge. Specifically, the apps are no longer being listed in the software app and the installation package - I'll speak to Chrome - doesn't appear to update the installed version, nor do the instructions listed on Install Google Chrome - Zorin Help successfully execute an installation. Rather than installing and listing the already installed version persists. I also noticed the Edge is also missing from the Software app listing.

Both Chrome and Edge are listed in the Zorin menu -> Settings -> Applications listing. Although they are listed when the "Open in Software" button is clicked an error is issued "Sorry! There are no details for that application."

Is there a repair procedure for applications that fall into a "blackhole" as described? It looks like the canonical installation is situated in /app/extra/chrome.

1 Like

Hi, and welcome to the ZorinOS Community.

If you open up a terminal window and run the following command, do you see any packages installed?

flatpak list

Sure there is plenty listed with flatpak list. I think this may be a multi architecture support issue related to the recent ZorinOS update perhaps. But please continue, what are your thoughts?

So, based on your suggestion to check the flatpak updates/list I did just that, and subsequently ran flatpak update and that's done it (the update to the flatpak list). Still can't grok what happened though. I'll check Edge next. Thanks for the suggestion.

Looks like that flatpak did the trick. Interestingly I now have two installations listed in the Settings -> Applications listing with different details as far as integration and what not.

I think I found the problem for the application listing, for what it's worth that seems to have been related to an apt(1) installation. Still not listing and gives the "Sorry!..." error though.

Are you saying that you have both a Flatpak and an APT version installed?

Do you have any errors in terminal if you try to install anything?

One of the Flatpak runtimes, for version < 43, has recently reached end-of-life, so it's possible this has been automatically removed by the Software Store. This is just a guess, as there's no reason why even having reached end-of-life it should stop working nor removed in the first place.

But different Flatpak packages have different requirements so it's a real possibility that Google Chrome, being from Google and due to potential security concerns, doesn't want to allow this. Microsoft Edge is a derivative of Chromium so it would explain why only these two packages are causing trouble, and at the same time.

This however doesn't really explain why the installation through .deb didn't work. I guess it's possible the installer contains instructions to check for the existence of Flatpak packages?

In any case, make a backup of whatever sensitive data you may have (bookmarks, etc) and try to remove them and install them again. Choose one source only, either .deb or Flatpak method, just to keep things simple. I would prefer to use .deb package since it's the native format and less likely to cause any trouble, and move to Flatpak only if you need some missing feature.


He may have installed the Debian version from Google directly and the Flatpak version from the software center thus the two version controversy.

Yes that was the issue - I did that while trying to suss out the updating issue. Interestingly, as I mentioned, from the UI I couldn't 'uninstall' so I just went to the recommended installation that I referenced in my original post on the matter. I've cleared that up now, but there is still no info listed in the Software App UI, which seems rather odd.

I like that approach. I have things sorted for now. I like to have a mostly one stop shop for the UI integrations too though, so there's that regarding the flatpak management of installations.

The .deb installer was complaining about i386 architecture support for the update download (the Google repository was not listed with the amd64 architecture exclusively) which was causing an issue with apt(1). The .deb installer worked, sure, but it didn't integrate the app with the UI automagically. Since I'm supporting some family by moving them to Zorin (a really good idea, btw), I want to also stay ahead of any potential complications they may run into.

I think you nailed it in one by directing me to check on the flatpak installation though. The working solution (although not for the Software App issue) was to run:

sudo flatpak update
sudo flatpak update

1 Like

Yes, and no. I did have both installed. No there were no installation errors. There was an error with "apt update" though. There was a multi architecture repository exclusion on the update that was fixed by editing the google repository. Interestingly the repository edit that was used boiled down to swapping the existing .list with a .save version in apt.sources.d


It is users choice after all. This side of the Pond the current issue of Computer Active's front cover is telling (Windows) users to stop using Browsers that spy on you, a.k.a., Chrome and Edge!


It's a pretty weird issue overall. I think in instances like this, re-installing would probably solve a lot of problems so it was an zero-effort guess :smiley:


Thank you community for all of the support. It's sorted now, but the Software app thing is a bit of a lost toy now. Cheers!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.