Chrome browser is running slow

Windows 10, 3 different installs of Zorin16.2 Pro, on different machines and even phones an tablets.
Chrome is taking forever to respond and repeatedly popping up {Wait] or [Reload} prompts.

Firefox works MUCH better at this point.

Is this from their stupid "Anti-Ad Blocking" initiative?
Cause I'm getting ready to ditch "Big G" all together.
Search gives me nothing for the last to years, and the last 2 weeks has been slow browser hell.

1 Like

Moved from "Customisation" to "General Help".

How was Chrome installed e.g. Flatpak, Snap or apt?
I don't use Chrome hence the question, but the packaging method may have something to do with its functioning.

2 Likes

Try SRWare Iron... it has versions for Windows and Linux (and even 32-bit versions, which Google no longer supports... so if you've still got an old computer with a 32-bit OS that you use, this is a good browser), and I'm using the same exact browser under Zorin OS as I used under Windows.

It's Google Chrome, with all the Google corporate spyware stripped out. The only extensions I use are uBlock Origin and TabActivate, but you can install any extensions you want from the Chrome Store.

I've not noticed any slowness from it.

1 Like

Topic title edited.

1 Like

I'm think it was through Software. Other wise I use *.deb files.

On Windows 10, the install was from Goggle Chrome website itself.

If through Software Store was it apt, Snap or Flatpak?
I don't use Chrome, so don't know what sources are listed for it on Software. Snaps and Flatpaks are sometimes more problematic.

I don't install any ad blockers in Firefox, just strict tracking protection. That suppress a lot of offensive ads. I don't consider all ads harmful and don't intend to become a free rider.

Don't know, I never used it enough to notice that, since I use Firefox I don't need to even think to Chrome. HELL, I DID IT RIGHT NOW :cry::rofl:.

I'd do the same if I wouldn't have much stuff connected to Google, so if I can I don't use it much, if I can use other providers I do it.

See if enabling hardware acceleration helps, :point_right: From the upper-right of your Chrome browser, click the three dots icon. Select Settings. Click Advanced and select System. Enable Use hardware acceleration when available.