Chrome browser not detecting system theme

Certain websites such as YouTube that detect and apply dark theme based on system theme do not work in Zorin the same as they do in windows. I have a dark mode extension but I like to whitelist the websites that have their own dark mode and it's annoying to keep changing it back when switching from Windows to Zorin. It also does not apply dark mode to settings. I have an extension in VS Code that also applies a theme based on system theme but doesn't work in Zorin for whatever reason so maybe it's not just a Chrome issue. Any fix for this?

Snap or Flatpak installed packages do not respect system themes.
If you installed Chrome from Snap - then there is nothing you can do other than remove the snap Chrome Package and then install Chrome as a .deb or Flatpak package.

If you installed as a Flatpak, then please see a way of making Flatpak respect system themes here:

I installed via .deb package from the Chrome website. Should I go with Flatpak instead? Where do I find it?

If it is a .deb, it should be respecting the theme.

Can you post screenshots to clarify what you are referring to?


Otherwise:
If using a Dark GTK Theme: in Settings > Appearance, ensure that GTK+ is selected, not classic.

Next, open a new tab and enter into the addressbar:
chrome://flags/
Under search - search dark mode
Two options should come up.
Allow widgets to inherit native theme from its parent widget. < Set this to enabled
Then next:
Auto Dark Mode for Web Contents < set this to enabled with selective inversion for non-image-elements

Relaunch Chrome and test


System is currently in dark theme. YouTube and settings don't detect it.

1 Like

Sorry - I got my brain into third gear finally and edited the post above...

I'm aware of the flags solution but wanted to see if there is a way to get it to pick up on the theme as it does on Windows.

Do you have the settings > appearance set to GTK or to Classic?

I wasn't sure so I just selected GTK then closed and relaunched. Same issue exept the setting drop down menu is now dark theme.

The tips above are really all there is (on Linux). Firefox can do a few more things such as using the gtk scrollbars and a menubar... but that is about all.
The browsers leave Inner Content to the webpages, not the browser, generally.

Thanks anyway, not too big of a deal just a minor annoyance. I just noticed that the YouTube site has a menu where I can toggle dark mode on and off so at least I can activate it that way however my dark mode extension has a setting to activate by system theme so I have to set that with the time scheduler instead.

I have tried various extensions with less than steller results...

I am trying out the flags option now, actually. It's not too bad.