Chrome – Firefox do not keep my login cookies

I’m not actually sure that the problem is with cookies. On Zorin, neither Chromium-browser nor Firefox will allow be to switch back and forth between 2 yahoo mail accounts. I must enter the the passwords every time. This does not happen on my Windows machine. I have Remember Me on the Yahoo page checked. I have options in the browsers set to save cookies from session to session.

In Firefox Privacy & Security settings, Manage Data, it says that data from websites in the following list are only deleted when space is needed. This is a new Zorin 15.3 install with 16 gigs of RAM and 1T of m.2 storage. It should have plenty of space. mail.yahoo.com is listed in this section.

In Firefox Exceptions – Cookies and Site Data, http://yahoo.com is listed as ALLOW.

During my testing they are not running in firejail. I invoke them like this in a terminal:

$firefox

$chromium-browser

What am I missing?

Note that I am not using either browser as a password manager.

Well … not what you were hoping for …

For none essential stuff I use GMail. For personal and private stuff I use the free version of Proton Mail - the Mail client used by the Novichok investigation team in Wiltshire (The Skrypal Poisonings).

Thanks for this. I was already aware of most of it. I do have a gmail account, but I don’t use it except for Google related accounts where an email is required. I tried changing my email about 20 years ago. I sent emails to everyone in my contacts list. Most kept right on sending to my old email address. So I sent it out again without much effect. Eventually, I just went back to my original email. Still, I’m going to read up on Proton mail. Having been a computer engineer for more than 50 years, I know full well that even when people are attempting to be honest they are still wrong. And what was true about a product such as Proton mail about 1 week ago is often no longer true.

The way to get your contacts to change is to alter the ‘reply-to’ element in your email - that way they should get the drift! I only started using Proton Mail after the co-ordinator of our Local Linux User Group advised me. Take care. :wink:

1 Like

I also use protonmail. If folks send to yahoo email, I then make my reply to them from protonmail and they start using it to send an email to me after that.
Yahoo email is delegated to what I fill out on forms on websites.

The experience you are having, you should not be having. Your Firefox defaults are stored in your home directory ~/.mozilla

@JimH Your Firefox wasn’t installed by way of Snap was it?

1 Like

This is a new install of Zorin. After doing tons of configurations, etc., I cannot honestly say for certain. I think it was pre-installed. I think the red fox icon that is on the win7-style taskbar was already there the first time I fired Zorin up. I found 2 config files in ~/.mozilla/firefox: install.ini and default.ini. They are extremely simple. There doesn’t seem to be anything relating to my problem in them.

On a FF Forum, I just read a few bits and pieces scattered around that said that Adobe Flash must be updated for FF to save passwords. While that sounds like nonsense to me, several different posters made the same claim.

Yes, that doesn’t sound reasonable. But it does indicate that I may not be the only one having problems. But it isn’t just FF. It’s also Chrome. I will try Vivaldi again to see if it has that problem on my machine.

Yes. It’s happening with Vivaldi, too. Normally, I would immediately think of a security app as the possible culprit. But I only have a firewall running: UFW. I’m scratching my head. I will look for where cookies are saved by FF on linux. Maybe that will tell me something. Something seems to be blocking cookie saves.

I found an article that says that FF stores its cookies in the sqlite3 database. In fact, I could find no folder holding cookies. So I searched the sqlite3 db using the sql provided in the article. I discovered that sqlite3 was not installed. I installed it. This did not fix my problem. Onward.

In order to see t e contents of the sqlite db, I’m supposed to ```
cd ~/.mozilla/firefox//
However, there do not seem to be any profile paths there. This is very confusing. I think I will uninstall FF and reinstall it from the ubuntu repository.

To leave things tidy, I’ll report that I uninstalled and reinstalled FF using the software manager app that comes with ZorinOS. Although I can now find some profiles, my problem has not changed. So that’s it for today. I’m going downstairs to pop some corn and watch another of the endless episodes of Star Trek Voyager.

2 Likes

End of story. Suddenly, Firefox has started saving cookies. I did say yes to install updates from the Zorin Software manager. I do not know if that fixed it. However, it still will not run properly in firejail. But that’s a story for another day.

You show me a company with contact info that’s in financial trouble and I’ll show you a company that sells contact info behind closed doors but then calls it a ‘data breach’.